aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@gmail.com>2020-12-10 12:12:19 +0100
committerMartin Mokrejs <mmokrejs@gmail.com>2020-12-10 12:13:08 +0100
commitf51d6ce27e5c393c5c28926cee6d87b89d0e699c (patch)
tree3e7ac897c9d58cecea51d1ab04a0a23d9c18c102 /sci-biology/rtg-tools
parentsci-biology/ABI-expression-data: removed version with missing distfiles (diff)
downloadsci-f51d6ce27e5c393c5c28926cee6d87b89d0e699c.tar.gz
sci-f51d6ce27e5c393c5c28926cee6d87b89d0e699c.tar.bz2
sci-f51d6ce27e5c393c5c28926cee6d87b89d0e699c.zip
sci-biology/rtg-tools: install missing files
The ebuild still needs some cleanup IMO, especially the rtg shell script which writes /etc/rtg.cfg and $bindir needs a fix. But one can run the jar file directly. Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Martin Mokrejs <mmokrejs@gmail.com>
Diffstat (limited to 'sci-biology/rtg-tools')
-rw-r--r--sci-biology/rtg-tools/rtg-tools-9999.ebuild26
1 files changed, 23 insertions, 3 deletions
diff --git a/sci-biology/rtg-tools/rtg-tools-9999.ebuild b/sci-biology/rtg-tools/rtg-tools-9999.ebuild
index b658f7c17..4f146be70 100644
--- a/sci-biology/rtg-tools/rtg-tools-9999.ebuild
+++ b/sci-biology/rtg-tools/rtg-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,13 +16,13 @@ IUSE=""
DEPEND="
>=virtual/jdk-1.8:*
- dev-java/ant-core
+ >=dev-java/ant-core-1.9
dev-java/jython"
RDEPEND="${DEPEND}
>=virtual/jre-1.8:*"
src_compile(){
- ant runalltests || die
+ ant zip-nojre || die
}
# "${S}"/lib/sam-2.9.1.jar
@@ -42,3 +42,23 @@ src_compile(){
# "${S}"/testLib/hamcrest-core-1.3.jar
# "${S}"/testLib/junit.jar
# "${S}"/testLib/spelling.jar
+
+src_install(){
+ dobin installer/rtg
+ insinto /usr/share/"${PN}"
+ doins build/rtg-tools.jar
+ doins lib/gzipfix.jar
+ dodoc installer/resources/tools/RTGOperationsManual.pdf
+ doins -r installer/resources/tools/RTGOperationsManual
+ dodoc installer/resources/tools/scripts/README.txt
+ dodoc installer/ReleaseNotes.txt
+ # TODO
+ # extract more files from the generated rtg-tools-3.11-39691f9f-base.zip
+ # file or better the installer/resources/ source directory
+ #
+ # install installer/resources/common/scripts/rtg-bash-completion
+}
+
+src_test(){
+ ant runalltests || die
+}