aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormschubert <mschu.dev@gmail.com>2016-01-23 21:59:18 +0000
committerJustin Lecher <jlec@gentoo.org>2016-02-28 10:43:14 +0000
commit78cab883d2457b52fb12f8a72ec7ce29c0d51950 (patch)
tree066b658cdaa9b264a5102d73bf801787f00bde9c /sci-biology/sailfish/sailfish-9999.ebuild
parentsci-biology/salmon: bump EAPI=6 (diff)
downloadsci-78cab883d2457b52fb12f8a72ec7ce29c0d51950.tar.gz
sci-78cab883d2457b52fb12f8a72ec7ce29c0d51950.tar.bz2
sci-78cab883d2457b52fb12f8a72ec7ce29c0d51950.zip
sci-biology/sailfish: add ebuild
Package-Manager: portage-2.2.20-prefix
Diffstat (limited to 'sci-biology/sailfish/sailfish-9999.ebuild')
-rw-r--r--sci-biology/sailfish/sailfish-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-biology/sailfish/sailfish-9999.ebuild b/sci-biology/sailfish/sailfish-9999.ebuild
new file mode 100644
index 000000000..2d60e34cb
--- /dev/null
+++ b/sci-biology/sailfish/sailfish-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Rapid Mapping-based Isoform Quantification from RNA-Seq Reads"
+HOMEPAGE="http://www.cs.cmu.edu/~ckingsf/software/sailfish/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/kingsfordgroup/sailfish.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.1-no-boost-static.patch )
+
+DEPEND="dev-libs/boost:0
+ dev-libs/jemalloc
+ dev-cpp/tbb"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ rm -r "${ED}"/usr/tests || die
+}