aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-03-09 17:44:10 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-03-09 17:44:10 +0100
commit53f3408793c23dd0612952d22bc4a6c599e2b295 (patch)
treecab23cfcfe47dd13146230ce9d957de6ae968b23 /sci-biology/sickle
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-53f3408793c23dd0612952d22bc4a6c599e2b295.tar.gz
sci-53f3408793c23dd0612952d22bc4a6c599e2b295.tar.bz2
sci-53f3408793c23dd0612952d22bc4a6c599e2b295.zip
respect CC and CFLAGS; added an ebuild for latest release tarball, works
Package-Manager: portage-2.2.15
Diffstat (limited to 'sci-biology/sickle')
-rw-r--r--sci-biology/sickle/ChangeLog6
-rw-r--r--sci-biology/sickle/Manifest1
-rw-r--r--sci-biology/sickle/sickle-1.33.ebuild36
-rw-r--r--sci-biology/sickle/sickle-9999.ebuild17
4 files changed, 57 insertions, 3 deletions
diff --git a/sci-biology/sickle/ChangeLog b/sci-biology/sickle/ChangeLog
index 443ff95fa..4d539a201 100644
--- a/sci-biology/sickle/ChangeLog
+++ b/sci-biology/sickle/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*sickle-1.33 (09 Mar 2015)
+
+ 09 Mar 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +sickle-1.33.ebuild,
+ sickle-9999.ebuild:
+ respect CC and CFLAGS; added an ebuild for latest release tarball, works
+
15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> sickle-9999.ebuild:
correct package description
diff --git a/sci-biology/sickle/Manifest b/sci-biology/sickle/Manifest
new file mode 100644
index 000000000..570d99efb
--- /dev/null
+++ b/sci-biology/sickle/Manifest
@@ -0,0 +1 @@
+DIST v1.33.tar.gz 631275 SHA256 eab271d25dc799e2ce67c25626128f8f8ed65e3cd68e799479bba20964624734 SHA512 94d9794861655c9d8688a4c71757ba93166f167ae529c5661998d287b93c6ccc9755d9e3db8d481bbd5dca4cf047f6266880a5fc1f8099e597bc857954404dcb WHIRLPOOL f54f911ddb58596c88aa2963a235a6c77f4b84d2c86f594329763c582763ffd7ccc86b28bf3d0126b9d8cd693c1a6cf1be05aa82d9521e5977b6ef0d01547a25
diff --git a/sci-biology/sickle/sickle-1.33.ebuild b/sci-biology/sickle/sickle-1.33.ebuild
new file mode 100644
index 000000000..2288aeaeb
--- /dev/null
+++ b/sci-biology/sickle/sickle-1.33.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils eutils toolchain-funcs
+
+[ "$PV" == "9999" ] && inherit git-r3
+
+DESCRIPTION="Windowed adaptive quality-based trimming tool for FASTQ data from Illumina/Solexa"
+HOMEPAGE="https://github.com/najoshi/sickle"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/najoshi/sickle"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/najoshi/sickle/archive/v"${PV}".tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-libs/zlib"
+
+src_prepare(){
+ sed -e "s#-pedantic#-pedantic ${CFLAGS}#;s#gcc#"$(tc-getCC)"#" -i Makefile || die
+}
+
+src_install(){
+ dobin sickle
+ dodoc README.md
+}
diff --git a/sci-biology/sickle/sickle-9999.ebuild b/sci-biology/sickle/sickle-9999.ebuild
index 022474e57..2288aeaeb 100644
--- a/sci-biology/sickle/sickle-9999.ebuild
+++ b/sci-biology/sickle/sickle-9999.ebuild
@@ -4,21 +4,32 @@
EAPI=5
-inherit eutils git-r3
+inherit eutils eutils toolchain-funcs
+
+[ "$PV" == "9999" ] && inherit git-r3
DESCRIPTION="Windowed adaptive quality-based trimming tool for FASTQ data from Illumina/Solexa"
HOMEPAGE="https://github.com/najoshi/sickle"
-EGIT_REPO_URI="https://github.com/najoshi/sickle"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/najoshi/sickle"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/najoshi/sickle/archive/v"${PV}".tar.gz"
+ KEYWORDS="~amd64"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
sys-libs/zlib"
+src_prepare(){
+ sed -e "s#-pedantic#-pedantic ${CFLAGS}#;s#gcc#"$(tc-getCC)"#" -i Makefile || die
+}
+
src_install(){
dobin sickle
dodoc README.md