aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 21:30:34 +0100
committerJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 22:57:41 +0100
commit9d417a388180071cd3607dd05447c20ccd789e21 (patch)
treee5e46435f24263dbca4677fd05870176f7dd3078 /sci-biology/tagdust
parentsci-biology/subread: Fix build with gcc-10 (diff)
downloadsci-9d417a388180071cd3607dd05447c20ccd789e21.tar.gz
sci-9d417a388180071cd3607dd05447c20ccd789e21.tar.bz2
sci-9d417a388180071cd3607dd05447c20ccd789e21.zip
sci-biology/tagdust: Port to EAPI 7
Closes: https://bugs.gentoo.org/755785 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
Diffstat (limited to 'sci-biology/tagdust')
-rw-r--r--sci-biology/tagdust/files/tagdust-20101028-fno-common.patch77
-rw-r--r--sci-biology/tagdust/tagdust-20101028.ebuild17
2 files changed, 85 insertions, 9 deletions
diff --git a/sci-biology/tagdust/files/tagdust-20101028-fno-common.patch b/sci-biology/tagdust/files/tagdust-20101028-fno-common.patch
new file mode 100644
index 000000000..01fd2d274
--- /dev/null
+++ b/sci-biology/tagdust/files/tagdust-20101028-fno-common.patch
@@ -0,0 +1,77 @@
+--- a/background.c
++++ b/background.c
+@@ -28,6 +28,9 @@
+ #include <ctype.h>
+ #define MIN(a, b) (a > b ? b : a)
+
++extern int *seed;
++extern int nuc_code[255];
++
+ /*
+
+ Collects length and nucleotide composition of the input reads. Simultaneously counts how many sequences are covered by x,x+1 ... percent library sequences
+--- a/detect.h
++++ b/detect.h
+@@ -70,11 +70,11 @@ struct stats_dat{
+ int *p_counts;
+ };
+
+-int nuc_code[255];
++extern int nuc_code[255];
+
+-int *seed;
++extern int *seed;
+
+-int linewrap;
++extern int linewrap;
+
+ void init_nuc_code();
+
+--- a/input.c
++++ b/input.c
+@@ -28,6 +28,10 @@
+ #include <ctype.h>
+
+ static int numseq = 0;
++extern int linewrap;
++extern int *seed;
++extern int nuc_code[255];
++
+
+
+ int compare(const void* a, const void* b)
+--- a/interface.c
++++ b/interface.c
+@@ -33,6 +33,8 @@
+ #define OPT_FASTA 5
+ #define OPT_MODEL 6
+
++extern int linewrap;
++
+ struct parameters* interface(struct parameters* param,int argc, char **argv)
+ {
+ int c;
+--- a/main.c
++++ b/main.c
+@@ -27,6 +27,10 @@
+ #include "detect.h"
+ #include "sys/time.h"
+
++int linewrap;
++int *seed;
++int nuc_code[255];
++
+
+ int main (int argc, char * argv[]) {
+ struct parameters* param = 0;
+--- a/test_sequence.c
++++ b/test_sequence.c
+@@ -26,6 +26,8 @@
+
+ #include "detect.h"
+
++extern int *seed;
++
+ /*
+ Checks if a sequence is covered by library sequences. Return the fraction of residues covered by library sequences.
+ */
diff --git a/sci-biology/tagdust/tagdust-20101028.ebuild b/sci-biology/tagdust/tagdust-20101028.ebuild
index 1357a0da5..2f5a1777e 100644
--- a/sci-biology/tagdust/tagdust-20101028.ebuild
+++ b/sci-biology/tagdust/tagdust-20101028.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Trim multimers of various primers/adapter from Illumina datasets"
HOMEPAGE="http://genome.gsc.riken.jp/osc/english/dataresource"
@@ -10,23 +10,22 @@ SRC_URI="http://genome.gsc.riken.jp/osc/english/software/src/tagdust.tgz -> ${P}
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+S="${WORKDIR}/tagdust"
-S="${WORKDIR}"/tagdust
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare(){
+ default
sed -e "s/^CFLAGS/#CFLAGS/" -e "s#/usr/local/bin#\$(DESTDIR)/usr/bin#" \
- -e "s#/usr/share/man/#\$(DESTDIR)/usr/share/man/#" -i Makefile
+ -e "s#/usr/share/man/#\$(DESTDIR)/usr/share/man/#" -i Makefile || die
}
-src_install(){
+src_install() {
doman tagdust.1
dobin tagdust
insinto /usr/share/tagdust/Illumina
- doins "test/"solexa*.fa
+ doins test/solexa*.fa
insinto /usr/share/tagdust
- doins "test/"protocol.txt README
+ doins test/protocol.txt README
}