aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-21 00:54:55 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-11-21 00:54:55 +0100
commite1a9394386238099ece40fe0e8d7f805c23b679d (patch)
treecc364ccde72d0f6181e866d0c390c21f5bc9d94e /sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild
parentsci-biology/parafly: document a recent upstream bugreport from github (diff)
downloadsci-e1a9394386238099ece40fe0e8d7f805c23b679d.tar.gz
sci-e1a9394386238099ece40fe0e8d7f805c23b679d.tar.bz2
sci-e1a9394386238099ece40fe0e8d7f805c23b679d.zip
sci-biology/trinityrnaseq: version bump but dropping KEYWORDS because we relocate *.pm file into vendor_perl and all 'use blah' calls to trinity-provided perl modules need to be changed to 'use trinityrnaseq::blah', or PERL5INC modified?
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild')
-rw-r--r--sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild b/sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild
new file mode 100644
index 000000000..0d5ba5346
--- /dev/null
+++ b/sci-biology/trinityrnaseq/trinityrnaseq-2.1.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module eutils toolchain-funcs
+
+# Butterfly should not require any special compilation, as its written in Java and already provided as portable precompiled software ...
+
+DESCRIPTION="Transcriptome assembler for RNA-seq reads"
+HOMEPAGE="http://trinityrnaseq.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-BroadInstitute"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sci-biology/parafly
+ =sci-biology/jellyfish-2.1.4
+ >=sci-libs/htslib-1.2.1
+ <=sci-biology/samtools-1.1
+ >=sci-biology/trimmomatic-0.32
+ dev-perl/IO-All"
+# ReleaseNotes mentions that <sci-biology/samtools-1.1 is needed
+# version of bundled jellyfish is 2.1.4
+# version of bundled samtools is 0.1.19
+# version of bundled htslib is 1.2.1
+# version of bundled GAL is 0.2.1
+# version of bundled trimmomatic is 0.32
+
+# optionally install https://github.com/HpcGridRunner/HpcGridRunner/releases
+
+src_prepare(){
+ epatch "${FILESDIR}"/disable_some_plugins.patch
+}
+
+#src_compile(){
+# emake all
+# emake plugins # bundled copies of TransDecoder, trimmomatic, fastool, parafly
+#}
+
+src_install(){
+ perl_set_version
+ dobin Trinity util/*.pl trinity-plugins/GAL_0.2.1/fasta_tool
+ # should become a new package depending on dev-perl/IO-All
+ dobin trinity-plugins/fstrozzi-Fastool-7c3e034f05/fastool
+ dodoc trinity-plugins/fstrozzi-Fastool-7c3e034f05/README.md
+ #
+ insinto /usr/share/"${PN}"/util
+ rm -f util/fasta_tool
+ doins -r util/*
+ #
+ dobin Inchworm/bin/*
+ cd Chrysalis
+ dobin MakeDepend checkLock BreakTransByPairs Chrysalis GraphFromFasta IsoformAugment JoinTransByPairs QuantifyGraph ReadsToTranscripts RunButterfly TranscriptomeFromVaryK analysis/ReadsToComponents.pl
+ cd "${S}" || die
+ insinto "${VENDOR_LIB}/${PN}"
+ doins util/misc/PerlLib/*.pm PerlLib/*.pm
+ insinto "${VENDOR_LIB}/${PN}"/KmerGraphLib
+ doins PerlLib/KmerGraphLib/*.pm
+ insinto "${VENDOR_LIB}/${PN}"/CDNA
+ doins PerlLib/CDNA/*.pm
+ insinto "${VENDOR_LIB}/${PN}"/HPC
+ doins PerlLib/HPC/*.pm
+ insinto "${VENDOR_LIB}/${PN}"/Simulate
+ doins PerlLib/Simulate/*.pm
+ insinto "${VENDOR_LIB}/${PN}"/CanvasXpress
+ doins PerlLib/CanvasXpress/*.pm
+ chmod a+rx -R "${ED}/${VENDOR_LIB}/${PN}"
+}