aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-18 14:10:38 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-18 14:12:58 +0100
commitfdcbbfa6d96ef8d4eb5a39bc6366bba3a9a743f1 (patch)
treeb015749d4c2928bb4b45877be17d4db2ed0cc592 /sci-biology/twinscan
parentsci-biology/twinscan: remove pack, obsolete and replaced upstream (diff)
downloadsci-fdcbbfa6d96ef8d4eb5a39bc6366bba3a9a743f1.tar.gz
sci-fdcbbfa6d96ef8d4eb5a39bc6366bba3a9a743f1.tar.bz2
sci-fdcbbfa6d96ef8d4eb5a39bc6366bba3a9a743f1.zip
sci-biology/twinscan: re-add, found the download link
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-biology/twinscan')
-rw-r--r--sci-biology/twinscan/Manifest1
-rw-r--r--sci-biology/twinscan/twinscan-4.1.2-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-biology/twinscan/Manifest b/sci-biology/twinscan/Manifest
new file mode 100644
index 000000000..81f4d8d86
--- /dev/null
+++ b/sci-biology/twinscan/Manifest
@@ -0,0 +1 @@
+DIST iscan-4.1.2.tar.gz 5894833 BLAKE2B 5d8b14694961eca181d8b7aeb0387f31b6f9eac77674a919df2d3c2aec1d65f845f4dd4ed937deb6c3d338389e545d9692d6f6b57db6cc7bac5ccadfb74c8714 SHA512 d216f790f6d0f35a070575d1aa4b5e1866c00132168b381b9177b076b1b2a16f2ecd7a88aa443d7ba6b8f62c3ec2595ba33c4608a674e09d94e9f7dc6a181327
diff --git a/sci-biology/twinscan/twinscan-4.1.2-r1.ebuild b/sci-biology/twinscan/twinscan-4.1.2-r1.ebuild
new file mode 100644
index 000000000..6b9a5f57c
--- /dev/null
+++ b/sci-biology/twinscan/twinscan-4.1.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="iscan (aka twinscan and N-SCAN), Pairagon wrapper: Gene structure pred. pipeline"
+HOMEPAGE="https://mblab.wustl.edu/software.html"
+#SRC_URI="https://mblab.wustl.edu/software/download/iscan-${PV}.tar_.gz -> ${P}.tar.gz"
+# ERROR: cannot verify mblab.wustl.edu's certificate, issued by ‘CN=InCommon RSA Server CA,OU=InCommon,O=Internet2,L=Ann Arbor,ST=MI,C=US’:
+# Unable to locally verify the issuer's authority.
+# To connect to mblab.wustl.edu insecurely, use `--no-check-certificate'.
+RESTRICT="fetch"
+SRC_URI="iscan-4.1.2.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/glib:2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/N-SCAN"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed "1 a use lib '/usr/share/${PN}/lib/perl5';" -i "${S}"/bin/*.pl || die
+ sed '/my $blast_param/ s/#//' -i "${S}/bin/runTwinscan2.pl" || die
+ tc-export CC AR RANLIB
+
+ sed \
+ -e 's:ar :$(AR) :g' \
+ -e 's:ranlib :$(RANLIB) :g' \
+ -e 's: -o : $(LDFLAGS) -o :g' \
+ -i Makefile || die
+
+ sed \
+ -e "/^GLIB_CFLAGS/s:=.*:=$($(tc-getPKG_CONFIG) --cflags glib-2.0) -DHAS_GLIB:g" \
+ -e "/^GLIB_LFLAGS/s:=.*:=$($(tc-getPKG_CONFIG) --libs glib-2.0) -DHAS_GLIB:g" \
+ -i Makefile.include || die
+}
+
+src_install() {
+ # TODO: prevent file collision with media-gfx/iscan by renaming iscan to iscan_twinscan
+ # also fix a Genscan++ToZoe.pl Nscan_driver.pl runTwinscan2.pl run_iscan.pl run_iscan_cons.pl run_iscan_cons_list.pl test.pl
+ rm src/test.pl || die
+ dobin bin/iscan bin/zoe2gtf bin/*.pl src/*.pl
+ dolib.so lib/libzoe.a
+ insinto /usr/share/${PN}
+ doins -r parameters
+ insinto /usr/share/${PN}/src
+ doins src/*.zhmm
+ perl_set_version
+ insinto ${VENDOR_LIB}/${PN}
+ doins lib/perl5/*.pm
+ echo "TWINSCAN=/usr" > "${S}"/99${PN}
+ doenvd "${S}"/99${PN}
+ rm -rf examples/tmp
+ dodoc examples/* README* src/doc/*.txt
+}
+
+pkg_postinst(){
+ einfo "Pairagon acts on output from either: sci-biology/gmap sci-biology/blat."
+ einfo "It also works on blastn output from WU-BLAST (not provided in Gentoo)."
+ einfo "It also calls blastz (seems superseded by LASTZ) and genscan++ (not provided in Gentoo)."
+ einfo "For some reason we have pslCDnaFilter provided only by sci-biology/ucsc-genome-browser"
+}