aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-01-08 23:37:29 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-01-08 23:37:29 +0100
commit1595e219f373ab70f35f7e7dc96c9aec10518de3 (patch)
tree49d5e447b38880c530395c9079e039ff163a0b2d /sci-biology
parentsci-biology/parafly: new package (diff)
downloadsci-1595e219f373ab70f35f7e7dc96c9aec10518de3.tar.gz
sci-1595e219f373ab70f35f7e7dc96c9aec10518de3.tar.bz2
sci-1595e219f373ab70f35f7e7dc96c9aec10518de3.zip
sci-biology/RADtools: manually install perl modules int PERL5INC path
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/RADtools/ChangeLog6
-rw-r--r--sci-biology/RADtools/RADtools-1.2.4.ebuild8
-rw-r--r--sci-biology/RADtools/RADtools-9999.ebuild10
3 files changed, 17 insertions, 7 deletions
diff --git a/sci-biology/RADtools/ChangeLog b/sci-biology/RADtools/ChangeLog
index 5896f967a..603811794 100644
--- a/sci-biology/RADtools/ChangeLog
+++ b/sci-biology/RADtools/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-biology/RADtools
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ RADtools-1.2.4.ebuild, RADtools-9999.ebuild:
+ sci-biology/RADtools: manually install perl modules int PERL5INC path
+
16 Sep 2014; Christoph Junghans <ottxor@gentoo.org> RADtools-1.2.4.ebuild,
RADtools-9999.ebuild:
removed empty line
diff --git a/sci-biology/RADtools/RADtools-1.2.4.ebuild b/sci-biology/RADtools/RADtools-1.2.4.ebuild
index 3000e763d..5dc2ef368 100644
--- a/sci-biology/RADtools/RADtools-1.2.4.ebuild
+++ b/sci-biology/RADtools/RADtools-1.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -32,5 +32,9 @@ RDEPEND="${DEPEND}"
src_install() {
dobin RADMIDs RADmarkers RADpools RADtags
mydoc="CHANGELOG RADmanual.pdf RADmanual.tex README"
- perl-module_src_install DESTDIR="${D}" # install RADtools.pm into @INC path
+ eval `perl '-V:installvendorlib'`
+ vendor_lib_install_dir="${installvendorlib}"
+ dodir ${vendor_lib_install_dir}
+ insinto ${vendor_lib_install_dir}
+ doins *.pm
}
diff --git a/sci-biology/RADtools/RADtools-9999.ebuild b/sci-biology/RADtools/RADtools-9999.ebuild
index 3000e763d..44754f54e 100644
--- a/sci-biology/RADtools/RADtools-9999.ebuild
+++ b/sci-biology/RADtools/RADtools-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit perl-module
-
[ "$PV" == "9999" ] && inherit git-2
DESCRIPTION="Tools for processing RAD Sequencing Illumina reads"
@@ -32,5 +30,9 @@ RDEPEND="${DEPEND}"
src_install() {
dobin RADMIDs RADmarkers RADpools RADtags
mydoc="CHANGELOG RADmanual.pdf RADmanual.tex README"
- perl-module_src_install DESTDIR="${D}" # install RADtools.pm into @INC path
+ eval `perl '-V:installvendorlib'`
+ vendor_lib_install_dir="${installvendorlib}"
+ dodir ${vendor_lib_install_dir}
+ insinto ${vendor_lib_install_dir}
+ doins *.pm
}