aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2012-01-30 01:57:29 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2012-01-30 01:57:29 +0100
commit2fcbf893286791d9d0139b9250938d57df54c65a (patch)
treebe4c95bce26c961bea3d1343320ad11318bf243b /sci-biology
parentAdded first ebuild for k3match, version 1.0 (diff)
downloadsci-2fcbf893286791d9d0139b9250938d57df54c65a.tar.gz
sci-2fcbf893286791d9d0139b9250938d57df54c65a.tar.bz2
sci-2fcbf893286791d9d0139b9250938d57df54c65a.zip
sci-biology/seaview: version bump; add missing symlink so that the C++ header can be found; remove calll to xft-config and use pkg-config instead; set our Gentoo FLTK path (not include path) to /usr/include/fltk-1 so that svg.o gets included during linking, otherwise we get undefined reference to svg_tree_save(FD_nj_plot*)
(Portage version: 2.1.10.44/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/seaview/ChangeLog13
-rw-r--r--sci-biology/seaview/Manifest1
-rw-r--r--sci-biology/seaview/metadata.xml16
-rw-r--r--sci-biology/seaview/seaview-4.3.3.ebuild69
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-biology/seaview/ChangeLog b/sci-biology/seaview/ChangeLog
new file mode 100644
index 000000000..cd6851bf0
--- /dev/null
+++ b/sci-biology/seaview/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-biology/seaview
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*seaview-4.3.3 (30 Jan 2012)
+
+ 30 Jan 2012; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +seaview-4.3.3.ebuild, +metadata.xml:
+ version bump; add missing symlink so that the C++ header can be found; remove
+ calll to xft-config and use pkg-config instead; set our Gentoo FLTK path (not
+ include path) to /usr/include/fltk-1 so that svg.o gets included during
+ linking, otherwise we get undefined reference to svg_tree_save(FD_nj_plot*)
+
diff --git a/sci-biology/seaview/Manifest b/sci-biology/seaview/Manifest
new file mode 100644
index 000000000..83381d590
--- /dev/null
+++ b/sci-biology/seaview/Manifest
@@ -0,0 +1 @@
+DIST seaview_4.3.3.tar.gz 313375 SHA256 632286397b4959ed8e379d6a6c57715a01634a81596ed681bcd87e14e10684b4 SHA512 cc3eb433c807b3482a4e883ffc96e00b8e04b6208561d3e7c7409da25e2171e5db7a0caa252070da904bd672d68f151967133ae0801fe2c6ffdee0d9af7ec8c3 WHIRLPOOL 0310a5e707c7314e3038a7e9467fa854868b691e7f4a82a75808ddf9197c8a98030414be67649c8b6def31a350899faa615c5d38a8f69966dc60080e51964915
diff --git a/sci-biology/seaview/metadata.xml b/sci-biology/seaview/metadata.xml
new file mode 100644
index 000000000..0c1ebc35d
--- /dev/null
+++ b/sci-biology/seaview/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+ <longdescription>
+ SeaView is a graphical multiple sequence alignment editor developped by
+ Manolo Gouy. SeaView is able to read and write various alignment
+ formats (NEXUS, MSF, CLUSTAL, FASTA, PHYLIP, MASE). It allows to
+ manually edit the alignment, and also to run DOT-PLOT or CLUSTALW
+ programs to locally improve the alignment.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/seaview/seaview-4.3.3.ebuild b/sci-biology/seaview/seaview-4.3.3.ebuild
new file mode 100644
index 000000000..b2cfe65b2
--- /dev/null
+++ b/sci-biology/seaview/seaview-4.3.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.5.ebuild,v 1.5 2011/03/20 20:02:27 jlec Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs multilib eutils base
+
+DESCRIPTION="A graphical multiple sequence alignment editor"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+xft"
+
+DEPEND="x11-libs/fltk:1
+ xft? ( x11-libs/libXft
+ x11-libs/fltk:1[xft] )"
+RDEPEND="${DEPEND}
+ sci-biology/clustalw
+ || ( sci-libs/libmuscle sci-biology/muscle )
+ sci-biology/phyml"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # respect CXXFLAGS (package uses them as CFLAGS)
+ sed -i \
+ -e "s:^CXX.*:CXX = $(tc-getCXX):" \
+ -e "s:\$(OPT):${CXXFLAGS}:" \
+ -e "s:^OPT:#OPT:" \
+ -e "s:^FLTK = /usr/include:FLTK = /usr/include/fltk-1:" \
+ -e "s:^#IFLTK .*:IFLTK = $(fltk-config --use-images --cflags):" \
+ -e "s:^#LFLTK .*:LFLTK = $(fltk-config --use-images --ldflags):" \
+ -e "s:^USE_XFT:#USE_XFT:" \
+ -e "s:^#HELPFILE:HELPFILE:" \
+ -e "s:/usr/share/doc/seaview/seaview.htm:/usr/share/seaview/seaview.htm:" \
+ -e "s:^#PHYMLNAME:PHYMLNAME:" \
+ Makefile || die "sed failed while editing Makefile"
+
+ if use xft; then
+ sed -i \
+ -e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(pkg-config --cflags xft):" \
+ -e "s:-lXft:$(pkg-config --libs xft):" \
+ Makefile || die "sed failed while editing Makefile to enable xft"
+ else
+ sed -i -e "s:-lXft::" Makefile || die
+ fi
+ cd FL || die
+ ln -sf . FL
+ base_src_prepare
+}
+
+src_install() {
+ dobin seaview || die
+
+ # /usr/share/seaview/seaview.html is hardcoded in the binary, see Makefile
+ insinto /usr/share/seaview
+ doins example.nxs seaview.html
+
+ insinto /usr/share/seaview/images
+ doins seaview.xpm || die
+
+ make_desktop_entry seaview Seaview
+
+ doman seaview.1 || die
+}