aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-24 14:57:44 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-24 14:57:44 +0100
commit57aaac2250383519cf73bc1d9d3fc20a1a3c8240 (patch)
treee4250f735035ff1d229314bd0cf9e328b952f753 /sci-biology
parentsci-biology/genepop: version bump, install PDF doc (diff)
downloadsci-57aaac2250383519cf73bc1d9d3fc20a1a3c8240.tar.gz
sci-57aaac2250383519cf73bc1d9d3fc20a1a3c8240.tar.bz2
sci-57aaac2250383519cf73bc1d9d3fc20a1a3c8240.zip
sci-biology/verifyBamID: new package, would benefit unbundling of libStatGen
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/verifyBamID/Manifest2
-rw-r--r--sci-biology/verifyBamID/metadata.xml12
-rw-r--r--sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/sci-biology/verifyBamID/Manifest b/sci-biology/verifyBamID/Manifest
new file mode 100644
index 000000000..a6034694d
--- /dev/null
+++ b/sci-biology/verifyBamID/Manifest
@@ -0,0 +1,2 @@
+DIST libStatGen-1.0.13.tar.gz 558682 SHA256 a67a3126fbf227a5c3a4de044447bf01eb8e091c737f7696449f764e42926339 SHA512 bcce3dd2f343e5941857d5bca0f2960d69b3e1083da6312e018a96bb92fb8dbc91ac511e062b024720c45508aa805d3f4f6511f60201438176a898ab789e746f WHIRLPOOL 533f255adc73d5aff0c45191d97a138723ff4a84e70f72bc0f66430b62071afe7ff6efa09d519ebce9954263b5c5a1a8ce066d648305aa2602a0d831abbdb6f6
+DIST verifyBamID-1.1.3.tar.gz 68447 SHA256 985584895e31b40422745d60542e5a30a3038ca735c65a8ba7802da58d721e22 SHA512 1b39b1f7b8a40f3c6c08af5a4ad24b8aebe5dc0dc3b1bf4401632fa6cac56dc8d5e17c18f142caa5cc00c7c654f43737b2550149f4c4416166f439688634235e WHIRLPOOL 97a3d0f3fcb0388d016b5406921eb63f3cd6585b827c0c7dbc0226325c77a113b7eb142fc0d2c1f6fe6535419c56e51946ffe9ff0c3b2f35e1e0ab7f70568f69
diff --git a/sci-biology/verifyBamID/metadata.xml b/sci-biology/verifyBamID/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/verifyBamID/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild b/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild
new file mode 100644
index 000000000..dfea2c485
--- /dev/null
+++ b/sci-biology/verifyBamID/verifyBamID-1.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Verify sample identity/mix and genotype concordance"
+HOMEPAGE="http://genome.sph.umich.edu/wiki/VerifyBamID"
+SRC_URI="https://github.com/statgen/verifyBamID/archive/v1.1.3.tar.gz -> ${P}.tar.gz
+ https://github.com/statgen/libStatGen/archive/v1.0.13.tar.gz -> libStatGen-1.0.13.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# DEPEND="sci-libs/libStatGen" # TODO: currently it uses its own bundled copy
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ default
+ # unpack ./libStatGen-1.0.13/ contents
+ gzip -dc "${DISTDIR}"/libStatGen-1.0.13.tar.gz | tar xf - || die
+ ln -s libStatGen-1.0.13 libStatGen || die
+ cd "${WORKDIR}" || die
+ ln -s libStatGen-1.0.13 libStatGen || die
+}
+
+src_compile(){
+ # LIB_PATH_GENERAL="${EPREFIX}"/usr/"$(get_libdir)" emake
+ LIB_PATH_GENERAL="../libStatGen-1.0.13" emake
+}
+
+src_install(){
+ dobin bin/verifyBamID
+}