aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-10 11:40:54 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-05-10 11:40:54 +0200
commit62fb9efa4877ad36d22202ddd025e5801fae9fb7 (patch)
tree32767f5b43ebb84966ce50aea1360f6010bbab34 /sci-biology
parentsci-biology/angsd: add default() to make EAPI=6 happy (diff)
downloadsci-62fb9efa4877ad36d22202ddd025e5801fae9fb7.tar.gz
sci-62fb9efa4877ad36d22202ddd025e5801fae9fb7.tar.bz2
sci-62fb9efa4877ad36d22202ddd025e5801fae9fb7.zip
sci-biology/last: version bump
The src_install() part does not re-introduce the *.sh and *.py file extensions like previous -299 ebuild. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/last/Manifest1
-rw-r--r--sci-biology/last/files/last-852-fix-build-system.patch54
-rw-r--r--sci-biology/last/files/last-852-portable-shebangs.patch56
-rw-r--r--sci-biology/last/last-852.ebuild42
-rw-r--r--sci-biology/last/metadata.xml8
5 files changed, 161 insertions, 0 deletions
diff --git a/sci-biology/last/Manifest b/sci-biology/last/Manifest
new file mode 100644
index 000000000..35ad39b82
--- /dev/null
+++ b/sci-biology/last/Manifest
@@ -0,0 +1 @@
+DIST last-852.zip 721683 SHA256 1b5d14e5238834cf9c50f950efc97e111977b101d12bc502eef5a8800ef724aa SHA512 9945967efb5025b72507dfeb28531e1595d9691096dc2d074711fd1f5cce92714341a387577b7c6054f3b2605084528817381ed6f39bd32e828341f4a06380b9 WHIRLPOOL 3c4e8d20ce12eef5d2844ad98f3025604d9387ec1cd1e06b36a953b0867717ef0e8b4788b48c7c1c3e0ac7158594f4a3a7092e56ca34b36e315f2e2a7f9e47b0
diff --git a/sci-biology/last/files/last-852-fix-build-system.patch b/sci-biology/last/files/last-852-fix-build-system.patch
new file mode 100644
index 000000000..6ee4f5a67
--- /dev/null
+++ b/sci-biology/last/files/last-852-fix-build-system.patch
@@ -0,0 +1,54 @@
+--- last-852/makefile.ori 2016-12-13 07:22:11.000000000 +0100
++++ last-852/makefile 2017-05-10 11:04:14.610665834 +0200
+@@ -1,6 +1,7 @@
+-CXXFLAGS = -O3 -std=c++11 -pthread -DHAS_CXX_THREADS
++CXXFLAGS ?= -O3
++CXXFLAGS += -std=c++11 -pthread -DHAS_CXX_THREADS
+ all:
+- @cd src && $(MAKE) CXXFLAGS="$(CXXFLAGS)"
++ $(MAKE) -C src
+
+ progs = src/lastdb src/lastal src/last-split src/last-merge-batches \
+ src/last-pair-probs src/lastdb8 src/lastal8 src/last-split8
+@@ -13,17 +14,17 @@
+ cp $(progs) scripts/* $(bindir)
+
+ clean:
+- @cd src && $(MAKE) clean
++ $(MAKE) -C src clean
+
+ html:
+- @cd doc && $(MAKE)
++ $(MAKE) -C doc
+
+ distdir = last-`hg id -n`
+
+ RSYNCFLAGS = -aC --exclude '*8' --exclude 'last??' --exclude last-split --exclude last-merge-batches --exclude last-pair-probs
+
+ dist: log html
+- @cd src && $(MAKE) version.hh CyclicSubsetSeedData.hh ScoreMatrixData.hh
++ $(MAKE) -C src version.hh CyclicSubsetSeedData.hh ScoreMatrixData.hh
+ rsync $(RSYNCFLAGS) build doc examples makefile scripts src data *.txt $(distdir)
+ zip -qrm $(distdir) $(distdir)
+
+--- last-852/src/makefile.ori 2016-12-13 06:53:24.000000000 +0100
++++ last-852/src/makefile 2017-05-10 11:05:22.792501835 +0200
+@@ -1,12 +1,13 @@
+-CXX = g++
+-CC = gcc
++CXX ?= g++
++CC ?= gcc
+
+-CXXFLAGS = -O3 -Wall -Wextra -Wcast-qual -Wswitch-enum -Wundef \
+--Wcast-align -pedantic -g -std=c++11 -pthread -DHAS_CXX_THREADS
++CXXFLAGS ?= -O3 -Wall -Wextra -Wcast-qual -Wswitch-enum -Wundef \
++-Wcast-align -pedantic -g
++CXXFLAGS += -std=c++11 -pthread -DHAS_CXX_THREADS
+ # -Wconversion
+ # -fomit-frame-pointer ?
+
+-CFLAGS = -Wall -O2
++CFLAGS ?= -Wall -O2
+
+ alpObj = alp/sls_alignment_evaluer.o alp/sls_pvalues.o \
+ alp/sls_alp_sim.o alp/sls_alp_regression.o alp/sls_alp_data.o \
diff --git a/sci-biology/last/files/last-852-portable-shebangs.patch b/sci-biology/last/files/last-852-portable-shebangs.patch
new file mode 100644
index 000000000..c2131da63
--- /dev/null
+++ b/sci-biology/last/files/last-852-portable-shebangs.patch
@@ -0,0 +1,56 @@
+--- last-852/scripts/last-dotplot.ori 2017-05-10 11:14:05.206748593 +0200
++++ last-852/scripts/last-dotplot 2017-05-10 11:15:31.009058957 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # Read pair-wise alignments in MAF or LAST tabular format: write an
+ # "Oxford grid", a.k.a. dotplot.
+--- last-852/scripts/last-map-probs.ori 2017-05-10 11:14:11.856927669 +0200
++++ last-852/scripts/last-map-probs 2017-05-10 11:15:35.139288498 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # Copyright 2010, 2011, 2012, 2014 Martin C. Frith
+
+--- last-852/scripts/last-postmask.ori 2017-05-10 11:14:19.817142021 +0200
++++ last-852/scripts/last-postmask 2017-05-10 11:15:44.939556158 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # Copyright 2014 Martin C. Frith
+
+--- last-852/scripts/last-train.ori 2017-05-10 11:14:27.687353953 +0200
++++ last-852/scripts/last-train 2017-05-10 11:15:48.679658384 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+ # Copyright 2015 Martin C. Frith
+
+ import math, optparse, os, random, signal, subprocess, sys, tempfile
+--- last-852/scripts/maf-convert.ori 2017-05-10 11:14:34.267531142 +0200
++++ last-852/scripts/maf-convert 2017-05-10 11:15:52.439761157 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+ # Copyright 2010, 2011, 2013, 2014 Martin C. Frith
+ # Read MAF-format alignments: write them in other formats.
+ # Seems to work with Python 2.x, x>=6
+--- last-852/scripts/maf-join.ori 2017-05-10 11:14:41.407723414 +0200
++++ last-852/scripts/maf-join 2017-05-10 11:15:56.699877600 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # Copyright 2009, 2010, 2011 Martin C. Frith
+
+--- last-852/scripts/maf-swap.ori 2017-05-10 11:14:48.417912185 +0200
++++ last-852/scripts/maf-swap 2017-05-10 11:16:02.300030669 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # Read MAF-format alignments, and write them, after moving the Nth
+ # sequence to the top in each alignment.
diff --git a/sci-biology/last/last-852.ebuild b/sci-biology/last/last-852.ebuild
new file mode 100644
index 000000000..b063550b3
--- /dev/null
+++ b/sci-biology/last/last-852.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-single-r1
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-${PV}-fix-build-system.patch
+ "${FILESDIR}"/${PN}-${PV}-portable-shebangs.patch
+)
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ local DOCS=( doc/*.txt ChangeLog.txt README.txt )
+ local HTML_DOCS=( doc/*html )
+ einstalldocs
+
+ dobin src/lastdb src/lastal src/last-split src/last-merge-batches \
+ src/last-pair-probs src/lastdb8 src/lastal8 src/last-split8
+
+ cd scripts || die
+ dobin *
+}
diff --git a/sci-biology/last/metadata.xml b/sci-biology/last/metadata.xml
new file mode 100644
index 000000000..959160fe4
--- /dev/null
+++ b/sci-biology/last/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>