aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@users.noreply.github.com>2013-11-18 12:00:10 -0800
committerJustin <jlec@users.noreply.github.com>2013-11-18 12:00:10 -0800
commit6c1c249794c2a3365a525c338ca62658e0a31992 (patch)
tree43a5c36dd79fcea20069d190d4988fe4043d345b /sci-biology
parentMerge pull request #143 from gentryx/master (diff)
parentcleanup (diff)
downloadsci-6c1c249794c2a3365a525c338ca62658e0a31992.tar.gz
sci-6c1c249794c2a3365a525c338ca62658e0a31992.tar.bz2
sci-6c1c249794c2a3365a525c338ca62658e0a31992.zip
Merge pull request #144 from mluessi/add_mne-python
ENH: mne-python ebuild
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mne-python/mne-python-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-biology/mne-python/mne-python-9999.ebuild b/sci-biology/mne-python/mne-python-9999.ebuild
new file mode 100644
index 000000000..583621642
--- /dev/null
+++ b/sci-biology/mne-python/mne-python-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 git-r3 virtualx
+
+DESCRIPTION="Python package for MEG and EEG data analysis"
+HOMEPAGE="http://martinos.org/mne/mne-python.html"
+EGIT_REPO_URI="https://github.com/mne-tools/mne-python.git"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test cuda"
+KEYWORDS=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_learn[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-biology/pysurfer[${PYTHON_USEDEP}]
+ sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cuda? (
+ dev-python/pycuda[${PYTHON_USEDEP}]
+ dev-python/scikits-cuda[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ test? ( dev-python/nose ${RDEPEND} )
+"
+
+run_test() {
+ PYTHONPATH=. MNE_SKIP_SAMPLE_DATASET_TESTS=1 nosetests -v mne
+}
+
+python_test() {
+ distutils_install_for_testing
+ esetup.py install --root="${T}/test-${EPYTHON}" --no-compile
+ # Link to test data that won't be included in the final installation
+ local TEST_DIR="${T}/test-${EPYTHON}/$(python_get_sitedir)"
+ cd ${S} || die
+ find . -type d -name data -exec ln -s ${S}/{} ${TEST_DIR}/{} \; || die
+ cd ${TEST_DIR} || die
+ VIRTUALX_COMMAND="run_test"
+ virtualmake
+}