aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-27 03:33:55 -0400
committerHorea Christian <chr@chymera.eu>2020-09-27 03:33:55 -0400
commit6fdee212269c999a4ec6ceb020115f6b9959d20f (patch)
treeeda9702c3fe91bb7c2484428b1dba3c9f342043c /sci-biology
parentsci-biology/pybedtools: PYTHON_COMPAT update and actually install files (diff)
downloadsci-6fdee212269c999a4ec6ceb020115f6b9959d20f.tar.gz
sci-6fdee212269c999a4ec6ceb020115f6b9959d20f.tar.bz2
sci-6fdee212269c999a4ec6ceb020115f6b9959d20f.zip
sci-biology/gffutils: version bump 0.10.1, test and PYTHON_COMPAT fix
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/gffutils/Manifest1
-rw-r--r--sci-biology/gffutils/gffutils-0.10.1.ebuild40
-rw-r--r--sci-biology/gffutils/gffutils-0.8.7.1.ebuild6
3 files changed, 44 insertions, 3 deletions
diff --git a/sci-biology/gffutils/Manifest b/sci-biology/gffutils/Manifest
index dbac0ec54..a697f0784 100644
--- a/sci-biology/gffutils/Manifest
+++ b/sci-biology/gffutils/Manifest
@@ -1 +1,2 @@
+DIST gffutils-0.10.1.tar.gz 1636628 BLAKE2B ca539bdcf2a2e199d264194e23c3d1b52e1f4b141d2a43a1346024c008020ff531d5b642c63bd4c3a34cd97de2a399975eea430163f16218f5a1d671521e69b6 SHA512 21f56e013abdf1368756db97afcea0be6d0edc56cb0636e9e796603959570c7c3ba0cecf1bf90a69ab7afd2c4c831d3d42b92960a8c34f9b645be7e47d42190a
DIST gffutils-0.8.7.1.tar.gz 1541112 BLAKE2B 65676cf0b910ad0fee478315409dba808a13d11922d0ab254694939ebd01f10b62c2237ae517d941999c6cf9bcb08d903bde8b9055bcf7a67116e14439ec4cca SHA512 4739dd402963d402f34a5e3da9cca7ba9586dcbbe62efbad89bf85c5dbb0feff0e260eea20563340911756e6817289c1556c261ef973a61f4e66e50efdfc8aa8
diff --git a/sci-biology/gffutils/gffutils-0.10.1.ebuild b/sci-biology/gffutils/gffutils-0.10.1.ebuild
new file mode 100644
index 000000000..f33541347
--- /dev/null
+++ b/sci-biology/gffutils/gffutils-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="GFF and GTF file manipulation and interconversion"
+HOMEPAGE="https://pythonhosted.org/gffutils/"
+SRC_URI="https://github.com/daler/gffutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ sci-biology/pybedtools[${PYTHON_USEDEP}]
+ sci-biology/pyfaidx[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ if use test; then
+ sed -i -e "s:/tmp/gffutils-test:${T}:g" gffutils/test/test.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests nose
+python_test() {
+ distutils_install_for_testing
+ nosetests -v -x --with-doctest -a '!slow' || die
+}
diff --git a/sci-biology/gffutils/gffutils-0.8.7.1.ebuild b/sci-biology/gffutils/gffutils-0.8.7.1.ebuild
index 787a5668a..333716f7a 100644
--- a/sci-biology/gffutils/gffutils-0.8.7.1.ebuild
+++ b/sci-biology/gffutils/gffutils-0.8.7.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1