aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-10-22 12:51:46 +0200
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-10-22 12:51:46 +0200
commitcad3d25dae697461e1a6d295f2bdf99e9c2f626a (patch)
treed067fe6fef4d8f546cab427a4a4ffdb8fc95caf8 /sci-biology
parentsci-libs/spyking-circus: new package (diff)
downloadsci-cad3d25dae697461e1a6d295f2bdf99e9c2f626a.tar.gz
sci-cad3d25dae697461e1a6d295f2bdf99e9c2f626a.tar.bz2
sci-cad3d25dae697461e1a6d295f2bdf99e9c2f626a.zip
sci-biology/staden: sourceforge moved SVN repo URL
Also, somehow I cannot set "${S}" to src because svn would checkout the source tree there, so one would need ./src/src to access configure.in. Overwriting "${S}" inside each function helps. Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/staden/staden-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-biology/staden/staden-9999.ebuild b/sci-biology/staden/staden-9999.ebuild
index 0253c9eb5..4be43217f 100644
--- a/sci-biology/staden/staden-9999.ebuild
+++ b/sci-biology/staden/staden-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -9,8 +9,7 @@ inherit autotools-utils flag-o-matic fortran-2 multilib subversion
DESCRIPTION="DNA sequence assembly (gap4, gap5), editing and analysis tools (Spin)"
HOMEPAGE="http://sourceforge.net/projects/staden/"
-SRC_URI=""
-ESVN_REPO_URI="https://staden.svn.sourceforge.net/svnroot/staden/staden/trunk/src"
+ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/${PN}/trunk"
LICENSE="staden"
SLOT="0"
@@ -42,6 +41,7 @@ RDEPEND="${DEPEND}
AUTOTOOLS_IN_SOURCE_BUILD=1
src_prepare() {
+ cd "${WORKDIR}"/"${P}"/src || die
sed \
-e 's:svnversion:false:' \
-i configure.in || die
@@ -50,6 +50,8 @@ src_prepare() {
}
src_configure() {
+ cd "${WORKDIR}"/"${P}"/src || die
+ S="${WORKDIR}"/"${P}"/src
local myeconfargs=()
use X && myeconfargs+=( --with-x )
myeconfargs+=(
@@ -62,7 +64,15 @@ src_configure() {
sed -e "s/^SVNVERS.*/SVNVERS = "${ESVN_REVISION}"/" -i system.mk || die
}
+src_compile(){
+ cd "${WORKDIR}"/"${P}"/src || die
+ S="${WORKDIR}"/"${P}"/src
+ default
+}
+
src_install() {
+ cd "${WORKDIR}"/"${P}"/src || die
+ S="${WORKDIR}"/"${P}"/src
autotools-utils_src_install SVN_VERSION="${ESVN_REVISION}"
cat >> "${T}"/99staden <<- EOF
STADENROOT="${EPREFIX}"/usr/share/staden