aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-01-04 15:41:40 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-01-04 15:41:40 +0100
commitd64b45637881bf496c6eaaf38a1047ac006958e6 (patch)
treec638616d5c702013b677f4c4b8e5a56086114cd5 /sci-biology
parentMerge branch 'master' of git+ssh://git.gentoo.org/proj/sci (diff)
downloadsci-d64b45637881bf496c6eaaf38a1047ac006958e6.tar.gz
sci-d64b45637881bf496c6eaaf38a1047ac006958e6.tar.bz2
sci-d64b45637881bf496c6eaaf38a1047ac006958e6.zip
sci-biology/ugene: version bump, maybe the >=Qt5-5.2.1 should be specified more properly?
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ugene/ChangeLog9
-rw-r--r--sci-biology/ugene/Manifest1
-rw-r--r--sci-biology/ugene/ugene-1.20.0.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/sci-biology/ugene/ChangeLog b/sci-biology/ugene/ChangeLog
index 9899da6b5..57d457cba 100644
--- a/sci-biology/ugene/ChangeLog
+++ b/sci-biology/ugene/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for sci-biology/ugene
-# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2016 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*ugene-1.20.0 (04 Jan 2016)
+
+ 04 Jan 2016; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +ugene-1.20.0.ebuild:
+ sci-biology/ugene: version bump, maybe the >=Qt5-5.2.1 should be specified
+ more properly?
+
*ugene-1.16.1 (09 May 2015)
09 May 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
diff --git a/sci-biology/ugene/Manifest b/sci-biology/ugene/Manifest
index e5d29d6b5..b7b88d8e2 100644
--- a/sci-biology/ugene/Manifest
+++ b/sci-biology/ugene/Manifest
@@ -1,2 +1,3 @@
DIST ugene-1.13.3.tar.gz 19098687 SHA256 043a6b3c6dcb9cb872bf2cd335e40a479ae62d333099e6cbe7ddd3663abda611 SHA512 6ae3645d25e37ee40d0e383dca1c6e0c05f388d3486326be24f5ecea9d7c8a2e1f82c302c21567339e47cd4d0fe404bfe1ada00fb7c7d2e5fc8e790e2d7c582b WHIRLPOOL 1b774e6e1e7c17de6c766bd3d97a024abee65e0a6061530e9e466f3597500c7f027ec91582363409576bda89316cbe7b01c784588844d8735f65dd2d4181b435
DIST ugene-1.16.1.tar.gz 20462247 SHA256 5d7dbbe0d2364ad72b947c53bb91cfa4b80eb2e8a1bd061149ce3354858c3074 SHA512 04a18f35c2884d77693efb710995c284c5e87a5634b21e089b885c78e05fee2f5afd8749d527f6a3bef57f96d13c7e58c7f96e50f72d3215d0bd89b824943d4f WHIRLPOOL e0c150a1d1799fa3e08ce58a56f47ca7530285020dbcd30576d63973fbf4c0a37b1e5e4319a4986f99bd5e099fa8307adc55a156784243ec57f3298abc3716d0
+DIST ugene-1.20.0.tar.gz 21194907 SHA256 618987aa599d8880b53fd6bf1938b2b57d7a6112c909b8cce9b21b05e7a36c5f SHA512 063d15de5ddd39876ac5364d7ec4313080bf2816fb5d0b78b9b8de9b5ae9b473019c6ee3f5494acba8391a6a052344d4737dbc968c6f307ce449d46717a1293a WHIRLPOOL 5c084b8a2bcbc583443d9406ad5c6fc612bf31959e84361af9f7112470fc8af22bdc02828e4bdbf160399fc661b2aaf4bbb8478ec882d7c25d6a41c757b90ec6
diff --git a/sci-biology/ugene/ugene-1.20.0.ebuild b/sci-biology/ugene/ugene-1.20.0.ebuild
new file mode 100644
index 000000000..206008c73
--- /dev/null
+++ b/sci-biology/ugene/ugene-1.20.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="A free open-source cross-platform bioinformatics software"
+HOMEPAGE="http://ugene.unipro.ru"
+SRC_URI="http://${PN}.unipro.ru/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2"
+
+# http://ugene.net/download.html states Qt5.4 and QtWebkit but:
+# Project MESSAGE: Cannot build Unipro UGENE with Qt version 4.8.7
+# Project ERROR: Use at least Qt 5.2.1.
+DEPEND="
+ >=dev-qt/qtgui-5.2.1"
+RDEPEND="${DEPEND}"
+
+LANGS="cs en ru zh"
+
+src_configure() {
+ local CONFIG_OPTS
+ if use amd64; then
+ CONFIG_OPTS+=( CONFIG+="x64" )
+ elif use ppc; then
+ CONFIG_OPTS+=( CONFIG+="ppc" )
+ fi
+
+ use cpu_flags_x86_sse2 && CONFIG_OPTS+=( use_sse2 )
+
+ eqmake4 $CONFIG_OPTS || die
+}