aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-26 23:13:52 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-26 23:13:52 +0100
commitdb6617fcd21401115d88ef59b233ae5430650d18 (patch)
tree6c70134e0d8731cad2ec9fb5ea629606f6ea1998 /sci-biology
parentsci-biology/flexbar: remove spaces (diff)
downloadsci-db6617fcd21401115d88ef59b233ae5430650d18.tar.gz
sci-db6617fcd21401115d88ef59b233ae5430650d18.tar.bz2
sci-db6617fcd21401115d88ef59b233ae5430650d18.zip
sci-biology/gbench and sci-biology/ncbi-tools++: do not download ncbi-vdb
Do not download sources from github during configure phase. This disables the feature completely. Somehow it does not find vdb binaries provided by our sci-biology/ncbi-tools++ package?
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/gbench/gbench-2.10.7.ebuild20
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild5
2 files changed, 22 insertions, 3 deletions
diff --git a/sci-biology/gbench/gbench-2.10.7.ebuild b/sci-biology/gbench/gbench-2.10.7.ebuild
index 4c57d1656..48e7f9d68 100644
--- a/sci-biology/gbench/gbench-2.10.7.ebuild
+++ b/sci-biology/gbench/gbench-2.10.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,6 +34,7 @@ RDEPEND="${PYTHON_DEPS}
media-libs/freetype
media-libs/giflib
media-libs/tiff:0=
+ || ( sci-biology/ncbi-tools++ sci-biology/sra_sdk )
gnutls? ( net-libs/gnutls )
hdf5? ( sci-libs/hdf5 )
sys-fs/fuse
@@ -70,6 +71,19 @@ src_configure(){
# configure: error: --datadir=/usr/share: unknown option; use --help to show usage
# configure: error: --sysconfdir=/etc: unknown option; use --help to show usage
# configure: error: --localstatedir=/var/lib: unknown option; use --help to show usage
- ./configure --prefix="${DESTDIR}"/"${EPREFIX}/usr" --libdir="${EPREFIX}/usr/$(get_libdir)" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ ./configure --prefix="${DESTDIR}"/"${EPREFIX}/usr" --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --without-downloaded-vdb \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
}
+
+# Doh, it runs git during configure phase if it could not find NCBI SRA VDB
+# by executing ./scripts/common/add_vdb.sh which points to https://github.com/ncbi/ncbi-vdb
+# But, we already have sci-biology/sra_sdk which blocks sci-biology/ncbi-tools++
+# as some file overlap. Seems ncbi-vdb is yet another smaller subset of either
+# of the two?
+#
+# Same come checking out ncbi-vdb should be in ncbi-tools++-18.0.0 .
+#
+# That behavior is entirely optional; you can suppress it by
+# configuring the Toolkit --without-downloaded-vdb, --with-vdb=PATH (e.g.,
+# --with-vdb=/usr), or --without-vdb altogether.
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index 179baeaea..5c91c1b0c 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -220,6 +220,11 @@ src_configure() {
--without-sybase
--with-autodep
# --with-3psw=std:netopt favor standard (system) builds of the above pkgs
+ # preventing executing git to checkout during configure phase ncbi-vdb sources
+ # resulting in 'checking for ncbi-vdb... no' and
+ # '^PACKAGES:'
+ # '^ disabled: ... VDB'
+ --without-downloaded-vdb
$(use_with debug)
$(use_with debug max-debug)
$(use_with debug symbols)