aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-04-01 04:22:33 -0400
committerHorea Christian <chr@chymera.eu>2022-04-01 04:22:33 -0400
commite3ed6312407f673e0d8d544fd54d625b6492a27a (patch)
tree25d58a02bb6281ea59109a737e1d3a243545c0a8 /sci-biology
parentsci-biology/afni: reinstated working versions (diff)
downloadsci-e3ed6312407f673e0d8d544fd54d625b6492a27a.tar.gz
sci-e3ed6312407f673e0d8d544fd54d625b6492a27a.tar.bz2
sci-e3ed6312407f673e0d8d544fd54d625b6492a27a.zip
sci-biology/afni: cleaned up whitespace and unneeded code
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/afni/afni-20.1.16.ebuild8
-rw-r--r--sci-biology/afni/afni-20.3.03.ebuild6
2 files changed, 5 insertions, 9 deletions
diff --git a/sci-biology/afni/afni-20.1.16.ebuild b/sci-biology/afni/afni-20.1.16.ebuild
index 98fdb2397..a95a34cfb 100644
--- a/sci-biology/afni/afni-20.1.16.ebuild
+++ b/sci-biology/afni/afni-20.1.16.ebuild
@@ -46,17 +46,17 @@ src_prepare() {
# Unbundle imcat
sed -e "s/ imcat / /g" \
-i Makefile.INCLUDE || die "Could not edit includes files."
- sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
+ sed -e "s~CC = /usr/bin/gcc -O2 -m64~CC = $(tc-getCC) \$(CFLAGS)~" \
-e "s~CCMIN = /usr/bin/gcc -m64~CCMIN = $(tc-getCC) \$(CFLAGS)~" \
- -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
- -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
+ -e "s~LD = /usr/bin/gcc~LD = $(tc-getCC)~" \
+ -e "s~AR = /usr/bin/ar~AR = $(tc-getAR)~" \
-e "s~RANLIB = /usr/bin/ranlib~RANLIB = $(tc-getRANLIB)~" \
-i Makefile || die "Could not edit Makefile"
# they provide somewhat problematic makefiles :(
sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
-i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
# upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
- find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EPREFIX}/usr/~g;" -i
default
}
diff --git a/sci-biology/afni/afni-20.3.03.ebuild b/sci-biology/afni/afni-20.3.03.ebuild
index fab7446bf..a95a34cfb 100644
--- a/sci-biology/afni/afni-20.3.03.ebuild
+++ b/sci-biology/afni/afni-20.3.03.ebuild
@@ -39,10 +39,6 @@ S="${WORKDIR}/${PN}-AFNI_${PV}/src"
BUILD="linux_fedora_19_64"
BIN_CONFLICTS=(qdelaunay whirlgif djpeg cjpeg qhull rbox count mpeg_encode)
-#PATCHES=(
-# "${FILESDIR}/${P}-python.patch"
-#)
-
src_prepare() {
eapply "${FILESDIR}/${P}-python.patch" || die
find -type f -exec sed -i -e "s/-lXp //g" {} +
@@ -60,7 +56,7 @@ src_prepare() {
sed -e "s~ifeq ($(CC),gcc)~ifeq (1,1)~"\
-i SUMA/SUMA_Makefile || die "Could not edit SUMA/SUMA_Makefile"
# upstream checks if $CC is EXACTLY gcc, else sets variables for Mac
- find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EROOT}/usr/~g;" -i
+ find "${S}" -iname "*Makefile*" | xargs sed -e "s~/usr/~${EPREFIX}/usr/~g;" -i
default
}