aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-01-04 12:13:11 +0100
committerJustin Lecher <jlec@gentoo.org>2017-01-04 11:13:11 +0000
commiteda8f3c599b7c146c971ba0295235a99604062b8 (patch)
tree9512ae9d7b4df640e15813127530455667cd596e /sci-biology
parentUpdate local USE description (diff)
downloadsci-eda8f3c599b7c146c971ba0295235a99604062b8.tar.gz
sci-eda8f3c599b7c146c971ba0295235a99604062b8.tar.bz2
sci-eda8f3c599b7c146c971ba0295235a99604062b8.zip
sci-biology/fsl: fixed outstanding FSLDIR and GUI issues (#716)
* sci-biology/fsl: addressing FSLDIR via symlinks * sci-biology/fsl: fixed FSL GUI Package-Manager: Portage-2.3.3, Repoman-2.3.1 * sci-biology/fsl: EAPI update Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/fsl/files/99fsl2
-rw-r--r--sci-biology/fsl/fsl-5.0.8.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/sci-biology/fsl/files/99fsl b/sci-biology/fsl/files/99fsl
index ca37941f9..41db5c514 100644
--- a/sci-biology/fsl/files/99fsl
+++ b/sci-biology/fsl/files/99fsl
@@ -2,4 +2,4 @@ FSLOUTPUTTYPE=NIFTI_GZ
FSLMULTIFILEQUIT=TRUE
FSLTCLSH=tclsh
FSLWISH=wish
-FSLDIR=/usr
+FSLDIR=/usr/share/fsl
diff --git a/sci-biology/fsl/fsl-5.0.8.ebuild b/sci-biology/fsl/fsl-5.0.8.ebuild
index 3e9dc991c..f6e57d189 100644
--- a/sci-biology/fsl/fsl-5.0.8.ebuild
+++ b/sci-biology/fsl/fsl-5.0.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils toolchain-funcs prefix
@@ -87,6 +87,7 @@ src_prepare(){
$(grep -rl "\'\${FSLDIR}\'/doc" src/*)
sed -i -e "s:\$FSLDIR/etc:/etc:g" `grep -rlI \$FSLDIR/etc *`
+ default
}
src_compile() {
@@ -127,6 +128,12 @@ src_install() {
# doins etc/matlab
#fi
+ #the following is needed for FSL and depending programs to be able
+ #to find its files, since FSL uses an uncommon:
+ #https://github.com/gentoo-science/sci/pull/612#r60289295
+ dosym /etc /usr/share/fsl/etc
+ dosym /usr/share/doc/${P} /usr/share/fsl/doc
+
doenvd "${FILESDIR}"/99fsl
mv "${ED}"/usr/bin/{,fsl_}cluster || die
}