aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-31 04:46:37 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 04:46:37 +0000
commitc3cb98a6a4ee1d7fad29a906f2e7fda3db04526a (patch)
treebe367d4729f6d4ca5e2d81a42598a108e09d7cc6 /sci-chemistry/MotionCor2
parentsci-chemistry/MotionCor2: drop old version (diff)
downloadsci-c3cb98a6a4ee1d7fad29a906f2e7fda3db04526a.tar.gz
sci-c3cb98a6a4ee1d7fad29a906f2e7fda3db04526a.tar.bz2
sci-c3cb98a6a4ee1d7fad29a906f2e7fda3db04526a.zip
sci-chemistry/MotionCor2: add symlink to binary
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-chemistry/MotionCor2')
-rw-r--r--sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild b/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
index 99b3b14cd..e1f880d28 100644
--- a/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
+++ b/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
@@ -11,7 +11,7 @@ S="${WORKDIR}"/${PN}_${PV}
LICENSE="UCSF-Motioncor2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="cuda92 cuda102"
+IUSE="cuda92 +cuda102"
REQUIRED_USE="^^ ( cuda92 cuda102 )"
RESTRICT="fetch"
@@ -37,9 +37,12 @@ src_install() {
# package also has 10.0 10.1 11.0 versions
# but these cuda versions are not in ::gentoo
+ local mcbin
if use cuda92; then
- dobin ${PN}_${PV}-Cuda92 ${PN}
+ mcbin="${PN}_${PV}_Cuda92"
elif use cuda102; then
- dobin ${PN}_${PV}-Cuda102 ${PN}
+ mcbin="${PN}_${PV}_Cuda102"
fi
+ dobin "${mcbin}"
+ dosym "${mcbin}" /usr/bin/MotionCor2
}