aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-26 22:32:14 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-26 22:32:31 +0200
commitd176083224f22427ef54190e4e00e9e3467b5973 (patch)
tree5d40c5eeffb4d3585e1d3bb39271a90a1c172504 /sci-chemistry/almost
parentsci-chemistry/mrbump superpose fix (diff)
downloadsci-d176083224f22427ef54190e4e00e9e3467b5973.tar.gz
sci-d176083224f22427ef54190e4e00e9e3467b5973.tar.bz2
sci-d176083224f22427ef54190e4e00e9e3467b5973.zip
Manifest
Diffstat (limited to 'sci-chemistry/almost')
-rw-r--r--sci-chemistry/almost/Manifest5
-rw-r--r--sci-chemistry/almost/almost-1.0.3-r2.ebuild24
-rw-r--r--sci-chemistry/almost/files/Makefile.patch44
-rw-r--r--sci-chemistry/almost/files/configure.patch226
-rw-r--r--sci-chemistry/almost/files/configure2.patch235
-rw-r--r--sci-chemistry/almost/files/gcc-4.3.patch10
6 files changed, 539 insertions, 5 deletions
diff --git a/sci-chemistry/almost/Manifest b/sci-chemistry/almost/Manifest
index 72eda44e9..bd7072cb7 100644
--- a/sci-chemistry/almost/Manifest
+++ b/sci-chemistry/almost/Manifest
@@ -1,6 +1,5 @@
AUX gcc-4.3.patch 1766 RMD160 56732dd9e2bb4fab2808c9f919e0393b10449216 SHA1 49347a5cc03f97feec2b1f3575ba0247e1c061c0 SHA256 f9aa5c578cb0ba24724ad11c12f81c96303ca3bb6700d6cdcf22656d6d1b3032
-DIST almost-1.0.3.tar.gz 14056910 RMD160 409a53f661876eb1fba702ee6cc62a2928a5c014 SHA1 bd9c21d1f0e802f66e30c9ad9794a2f9ce98c5da SHA256 94893ce43f50e426c9ecfba67c5a555307ba9eb19b2a2034a69e5828778e9632
-EBUILD almost-1.0.3-r1.ebuild 1386 RMD160 185f09733f202f5360872ad09e270d751c80e906 SHA1 49839d30f16303f53fcef0e4691761a11214b1f7 SHA256 b741bf0d3f554263d3ebbd2f1e091e5925e92bb1f05ad81eeeb1659957a08628
-EBUILD almost-1.0.3.ebuild 1386 RMD160 185f09733f202f5360872ad09e270d751c80e906 SHA1 49839d30f16303f53fcef0e4691761a11214b1f7 SHA256 b741bf0d3f554263d3ebbd2f1e091e5925e92bb1f05ad81eeeb1659957a08628
+DIST almost-1.0.3-090822.tar.gz 10973194 RMD160 e1aaa736cc063275ecca347e4f483d5787bc2db3 SHA1 b8565ff71fb65e9f7e615050f1995b9cdd3087d0 SHA256 1e6351cc9de342c2d1ce64b4c44b66b482f7c2267dc0eca39ca2452e7b33422a
+EBUILD almost-1.0.3-r2.ebuild 1409 RMD160 38da0515bd81ffa026a575d36b60762a497cca91 SHA1 5e8be7e8589f2d9b632958a3ba5f492c44c70b20 SHA256 e73ef2a304bd9a703ab06c26a39284aac5b89394c63d8ff559fa2efcc5ad98d4
MISC ChangeLog 514 RMD160 9f56e4d70dc7773c122a9af56c7e473e2f5dd3a6 SHA1 bd4b98558738b91c912754344ec49bd982563a95 SHA256 8f29f46a6f400801dc6d7ddd5df55248b99ca00286c4245290c2f950d5a00fa1
MISC metadata.xml 268 RMD160 adbf63d25b16c6d9199c20ab0092b9a75a851605 SHA1 ffc9c0fba9a923d9ba5326283b60c31573888cf3 SHA256 6a8f1e47a14b8730b4a7ba9e0f0055ab4d6071ebcaf12bb601e8b949223c0c7f
diff --git a/sci-chemistry/almost/almost-1.0.3-r2.ebuild b/sci-chemistry/almost/almost-1.0.3-r2.ebuild
index 1666b5fd5..f91b72300 100644
--- a/sci-chemistry/almost/almost-1.0.3-r2.ebuild
+++ b/sci-chemistry/almost/almost-1.0.3-r2.ebuild
@@ -4,11 +4,13 @@
inherit eutils flag-o-matic autotools
+DATE="090822"
+
DESCRIPTION="all atom molecular simulation toolkit"
HOMEPAGE="http://www-almost.ch.cam.ac.uk/site"
#SRC_URI="http://www-almost.ch.cam.ac.uk/site/downloads/${P}.tar.gz"
## Upstream changes tarballs w/o revision bump so I host a copy
-SRC_URI="http://gentoo.j-schmitz.net/portage/distfiles/ALL/${P}.tar.gz"
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}-${DATE}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -31,6 +33,24 @@ src_unpack(){
cd "${S}"
+ rm -rf ./include/almost/boost src/lib/iostreams
+# rm -rf ./include/almost/boost ./include/almost/boost_1_30 #src/lib/iostreams
+
+ sed -e 's:boost boost_1_30::g' \
+ -i ./include/almost/Makefile.am
+
+ epatch "${FILESDIR}"/configure2.patch
+ epatch "${FILESDIR}"/Makefile.patch
+
+ sed \
+ -e '/include\/almost\/boost/d' \
+ -e '/include\/almost\/tinyxml/d' \
+ -i configure.in
+
+# find include \
+# -name "*.h" \
+# -exec sed 's:boost_1_30:boost:g' -i '{}' \;
+
epatch "${FILESDIR}"/gcc-4.3.patch
eautoreconf || die "Reconfiguration failed"
}
@@ -39,7 +59,7 @@ src_compile(){
econf || die "configure failed"
- emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || \
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" -j1 || \
die "make failed"
}
diff --git a/sci-chemistry/almost/files/Makefile.patch b/sci-chemistry/almost/files/Makefile.patch
new file mode 100644
index 000000000..cdaf0aa2f
--- /dev/null
+++ b/sci-chemistry/almost/files/Makefile.patch
@@ -0,0 +1,44 @@
+--- src/Makefile.am 2008-06-06 01:15:31.000000000 +0200
++++ src/Makefile.am.new 2009-08-22 22:38:00.000000000 +0200
+@@ -1,3 +1,3 @@
+ #SUBDIRS = #io param pdb molecules util moveset system forcefield zeta mpi dcdtools analysis modules tests
+
+-SUBDIRS= lib tinyxml libxml forcefield examples tests
++SUBDIRS= lib forcefield examples tests
+--- src/lib/Makefile.am 2008-07-17 17:57:14.000000000 +0200
++++ src/lib/Makefile.am.new 2009-08-23 20:45:00.000000000 +0200
+@@ -1,6 +1,7 @@
+ INCLUDES = -I../../include/almost -I../rose -I../zeta/ -Imodules
+ SUBDIRS=modules
+ lib_LIBRARIES=libAlm.a
++libAlm_la_LIBADD=libboost_iostreams.a
+ REGEXSOURCES= regex/c_regex_traits.cpp \
+ regex/cpp_regex_traits.cpp \
+ regex/cregex.cpp \
+@@ -19,15 +20,6 @@
+ regex/wide_posix_api.cpp \
+ regex/winstances.cpp
+
+-IOSTREAMSSOURCES = iostreams/bzip2.cpp \
+- iostreams/file_descriptor.cpp \
+- iostreams/mapped_file.cpp \
+- iostreams/zlib.cpp
+-
+-IOSOURCES = io/formostream.cpp
+-
+-
+-
+ PBDSOURCES = pdb/pdbatomline.cpp \
+ pdb/pdbauthorline.cpp \
+ pdb/pdbcompndline.cpp \
+@@ -208,8 +200,8 @@
+
+
+
+-nodist_libAlm_a_SOURCES= $(REGEXSOURCES) $(PBDSOURCES) $(IOSTREAMSSOURCES) \
+- $(IOSOURCES) $(MDBSOUCES) $(MOLECULESSOURCES) \
++nodist_libAlm_a_SOURCES= $(REGEXSOURCES) $(PBDSOURCES) \
++ $(MDBSOUCES) $(MOLECULESSOURCES) \
+ $(MOVESETSOURCES) $(DCDTOOLSSOURCES) $(ALGOSOURCES) \
+ $(MODSOURCES) $(CODE) $(ZETASOURCES) $(CHESHIRESOURCES)
+
diff --git a/sci-chemistry/almost/files/configure.patch b/sci-chemistry/almost/files/configure.patch
new file mode 100644
index 000000000..c8e27198d
--- /dev/null
+++ b/sci-chemistry/almost/files/configure.patch
@@ -0,0 +1,226 @@
+--- configure.in 2008-06-18 11:53:20.000000000 +0200
++++ configure.in.new 2009-08-22 22:07:07.000000000 +0200
+@@ -125,10 +125,6 @@
+ fi
+
+
+-#C and CPPFLAFS
+-CFLAGS="-O9 -ffast-math -fomit-frame-pointer"
+-CXXFLAGS="-O9 -ffast-math"
+-
+ #alm_sse
+ mkasm=false
+ case "${host-cpu}" in
+@@ -224,203 +220,6 @@
+ version.h
+ Makefile
+ include/almost/algorithm/Makefile
+- include/almost/boost/algorithm/Makefile
+- include/almost/boost/algorithm/string/detail/Makefile
+- include/almost/boost/algorithm/string/Makefile
+- include/almost/boost/algorithm/string/std/Makefile
+- include/almost/boost/archive/detail/Makefile
+- include/almost/boost/archive/impl/Makefile
+- include/almost/boost/archive/iterators/Makefile
+- include/almost/boost/archive/Makefile
+- include/almost/boost/assign/Makefile
+- include/almost/boost/assign/std/Makefile
+- include/almost/boost/bind/Makefile
+- include/almost/boost/compatibility/cpp_c_headers/Makefile
+- include/almost/boost/compatibility/Makefile
+- include/almost/boost/config/abi/Makefile
+- include/almost/boost/config/compiler/Makefile
+- include/almost/boost/config/Makefile
+- include/almost/boost/config/platform/Makefile
+- include/almost/boost/config/stdlib/Makefile
+- include/almost/boost/date_time/gregorian/Makefile
+- include/almost/boost/date_time/local_time/Makefile
+- include/almost/boost/date_time/Makefile
+- include/almost/boost/date_time/posix_time/Makefile
+- include/almost/boost/detail/Makefile
+- include/almost/boost/dynamic_bitset/Makefile
+- include/almost/boost/filesystem/Makefile
+- include/almost/boost/format/detail/Makefile
+- include/almost/boost/format/Makefile
+- include/almost/boost/function/detail/Makefile
+- include/almost/boost/function/Makefile
+- include/almost/boost/functional/detail/Makefile
+- include/almost/boost/functional/hash/Makefile
+- include/almost/boost/functional/Makefile
+- include/almost/boost/graph/detail/Makefile
+- include/almost/boost/graph/Makefile
+- include/almost/boost/integer/Makefile
+- include/almost/boost/io/Makefile
+- include/almost/boost/iostreams/detail/adapter/Makefile
+- include/almost/boost/iostreams/detail/broken_overload_resolution/Makefile
+- include/almost/boost/iostreams/detail/config/Makefile
+- include/almost/boost/iostreams/detail/Makefile
+- include/almost/boost/iostreams/detail/streambuf/Makefile
+- include/almost/boost/iostreams/detail/vc6/Makefile
+- include/almost/boost/iostreams/device/Makefile
+- include/almost/boost/iostreams/filter/Makefile
+- include/almost/boost/iostreams/Makefile
+- include/almost/boost/iterator/detail/Makefile
+- include/almost/boost/iterator/Makefile
+- include/almost/boost/lambda/detail/Makefile
+- include/almost/boost/lambda/Makefile
+- include/almost/boost/logic/Makefile
+- include/almost/boost/Makefile
+- include/almost/boost/math/Makefile
+- include/almost/boost/math/special_functions/Makefile
+- include/almost/boost/mpl/aux_/config/Makefile
+- include/almost/boost/mpl/aux_/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/bcc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/bcc551/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/dmc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/gcc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/msvc60/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/msvc70/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/mwcw/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/no_ttp/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/aux_/preprocessor/Makefile
+- include/almost/boost/mpl/aux_/range_c/Makefile
+- include/almost/boost/mpl/aux_/test/Makefile
+- include/almost/boost/mpl/limits/Makefile
+- include/almost/boost/mpl/list/aux_/Makefile
+- include/almost/boost/mpl/list/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/list/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/list/Makefile
+- include/almost/boost/mpl/Makefile
+- include/almost/boost/mpl/map/aux_/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/typeof_based/Makefile
+- include/almost/boost/mpl/map/Makefile
+- include/almost/boost/mpl/math/Makefile
+- include/almost/boost/mpl/multiset/aux_/Makefile
+- include/almost/boost/mpl/multiset/Makefile
+- include/almost/boost/mpl/set/aux_/Makefile
+- include/almost/boost/mpl/set/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/set/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/set/Makefile
+- include/almost/boost/mpl/vector/aux_/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/typeof_based/Makefile
+- include/almost/boost/mpl/vector/Makefile
+- include/almost/boost/multi_array/Makefile
+- include/almost/boost/multi_index/detail/Makefile
+- include/almost/boost/multi_index/Makefile
+- include/almost/boost/numeric/conversion/detail/Makefile
+- include/almost/boost/numeric/conversion/Makefile
+- include/almost/boost/numeric/interval/compare/Makefile
+- include/almost/boost/numeric/interval/detail/Makefile
+- include/almost/boost/numeric/interval/ext/Makefile
+- include/almost/boost/numeric/interval/Makefile
+- include/almost/boost/numeric/Makefile
+- include/almost/boost/numeric/ublas/detail/Makefile
+- include/almost/boost/numeric/ublas/Makefile
+- include/almost/boost/optional/Makefile
+- include/almost/boost/parameter/aux_/Makefile
+- include/almost/boost/parameter/Makefile
+- include/almost/boost/pending/detail/Makefile
+- include/almost/boost/pending/Makefile
+- include/almost/boost/pool/detail/Makefile
+- include/almost/boost/pool/Makefile
+- include/almost/boost/preprocessor/arithmetic/detail/Makefile
+- include/almost/boost/preprocessor/arithmetic/Makefile
+- include/almost/boost/preprocessor/array/Makefile
+- include/almost/boost/preprocessor/comparison/Makefile
+- include/almost/boost/preprocessor/config/Makefile
+- include/almost/boost/preprocessor/control/detail/dmc/Makefile
+- include/almost/boost/preprocessor/control/detail/edg/Makefile
+- include/almost/boost/preprocessor/control/detail/Makefile
+- include/almost/boost/preprocessor/control/detail/msvc/Makefile
+- include/almost/boost/preprocessor/control/Makefile
+- include/almost/boost/preprocessor/debug/Makefile
+- include/almost/boost/preprocessor/detail/dmc/Makefile
+- include/almost/boost/preprocessor/detail/Makefile
+- include/almost/boost/preprocessor/facilities/Makefile
+- include/almost/boost/preprocessor/iteration/detail/bounds/Makefile
+- include/almost/boost/preprocessor/iteration/detail/iter/Makefile
+- include/almost/boost/preprocessor/iteration/detail/Makefile
+- include/almost/boost/preprocessor/iteration/Makefile
+- include/almost/boost/preprocessor/list/detail/dmc/Makefile
+- include/almost/boost/preprocessor/list/detail/edg/Makefile
+- include/almost/boost/preprocessor/list/detail/Makefile
+- include/almost/boost/preprocessor/list/Makefile
+- include/almost/boost/preprocessor/logical/Makefile
+- include/almost/boost/preprocessor/Makefile
+- include/almost/boost/preprocessor/punctuation/Makefile
+- include/almost/boost/preprocessor/repetition/detail/dmc/Makefile
+- include/almost/boost/preprocessor/repetition/detail/edg/Makefile
+- include/almost/boost/preprocessor/repetition/detail/Makefile
+- include/almost/boost/preprocessor/repetition/detail/msvc/Makefile
+- include/almost/boost/preprocessor/repetition/Makefile
+- include/almost/boost/preprocessor/selection/Makefile
+- include/almost/boost/preprocessor/seq/detail/Makefile
+- include/almost/boost/preprocessor/seq/Makefile
+- include/almost/boost/preprocessor/slot/detail/Makefile
+- include/almost/boost/preprocessor/slot/Makefile
+- include/almost/boost/preprocessor/tuple/Makefile
+- include/almost/boost/program_options/detail/Makefile
+- include/almost/boost/program_options/Makefile
+- include/almost/boost/ptr_container/detail/Makefile
+- include/almost/boost/ptr_container/Makefile
+- include/almost/boost/python/converter/Makefile
+- include/almost/boost/python/detail/Makefile
+- include/almost/boost/python/Makefile
+- include/almost/boost/python/object/Makefile
+- include/almost/boost/python/suite/indexing/detail/Makefile
+- include/almost/boost/python/suite/indexing/Makefile
+- include/almost/boost/python/suite/Makefile
+- include/almost/boost/random/detail/Makefile
+- include/almost/boost/random/Makefile
+- include/almost/boost/range/detail/Makefile
+- include/almost/boost/range/detail/mfc/Makefile
+- include/almost/boost/range/detail/vc6/Makefile
+- include/almost/boost/range/Makefile
+- include/almost/boost/regex/config/Makefile
+- include/almost/boost/regex/Makefile
+- include/almost/boost/regex/pending/Makefile
+- include/almost/boost/regex/v4/Makefile
+- include/almost/boost/serialization/detail/Makefile
+- include/almost/boost/serialization/Makefile
+- include/almost/boost/signals/detail/Makefile
+- include/almost/boost/signals/Makefile
+- include/almost/boost/thread/detail/Makefile
+- include/almost/boost/thread/Makefile
+- include/almost/boost/tuple/detail/Makefile
+- include/almost/boost/tuple/Makefile
+- include/almost/boost/type_traits/detail/Makefile
+- include/almost/boost/type_traits/Makefile
+- include/almost/boost/utility/detail/Makefile
+- include/almost/boost/utility/Makefile
+- include/almost/boost/variant/detail/Makefile
+- include/almost/boost/variant/Makefile
+- include/almost/boost/wave/cpplexer/Makefile
+- include/almost/boost/wave/cpplexer/re2clex/Makefile
+- include/almost/boost/wave/grammars/Makefile
+- include/almost/boost/wave/Makefile
+- include/almost/boost/wave/util/Makefile
+- include/almost/boost_1_30/config/compiler/Makefile
+- include/almost/boost_1_30/config/Makefile
+- include/almost/boost_1_30/config/platform/Makefile
+- include/almost/boost_1_30/config/stdlib/Makefile
+- include/almost/boost_1_30/detail/Makefile
+- include/almost/boost_1_30/Makefile
+- include/almost/boost_1_30/random/detail/Makefile
+- include/almost/boost_1_30/random/Makefile
+ include/almost/coormanager/Makefile
+ include/almost/dyna/Makefile
+ include/almost/mcf/Makefile
+@@ -470,8 +269,6 @@
+ src/lib/Makefile
+ src/lib/modules/Makefile
+ src/Makefile
+- src/tinyxml/Makefile
+- src/libxml/Makefile
+ src/forcefield/Makefile
+ src/examples/Makefile
+ src/tests/Makefile
diff --git a/sci-chemistry/almost/files/configure2.patch b/sci-chemistry/almost/files/configure2.patch
new file mode 100644
index 000000000..bf598ae87
--- /dev/null
+++ b/sci-chemistry/almost/files/configure2.patch
@@ -0,0 +1,235 @@
+--- configure.in 2008-06-18 11:53:20.000000000 +0200
++++ configure.in.new 2009-08-23 22:10:20.000000000 +0200
+@@ -124,11 +124,6 @@
+ echo Constraint disabled value $
+ fi
+
+-
+-#C and CPPFLAFS
+-CFLAGS="-O9 -ffast-math -fomit-frame-pointer"
+-CXXFLAGS="-O9 -ffast-math"
+-
+ #alm_sse
+ mkasm=false
+ case "${host-cpu}" in
+@@ -224,195 +219,6 @@
+ version.h
+ Makefile
+ include/almost/algorithm/Makefile
+- include/almost/boost/algorithm/Makefile
+- include/almost/boost/algorithm/string/detail/Makefile
+- include/almost/boost/algorithm/string/Makefile
+- include/almost/boost/algorithm/string/std/Makefile
+- include/almost/boost/archive/detail/Makefile
+- include/almost/boost/archive/impl/Makefile
+- include/almost/boost/archive/iterators/Makefile
+- include/almost/boost/archive/Makefile
+- include/almost/boost/assign/Makefile
+- include/almost/boost/assign/std/Makefile
+- include/almost/boost/bind/Makefile
+- include/almost/boost/compatibility/cpp_c_headers/Makefile
+- include/almost/boost/compatibility/Makefile
+- include/almost/boost/config/abi/Makefile
+- include/almost/boost/config/compiler/Makefile
+- include/almost/boost/config/Makefile
+- include/almost/boost/config/platform/Makefile
+- include/almost/boost/config/stdlib/Makefile
+- include/almost/boost/date_time/gregorian/Makefile
+- include/almost/boost/date_time/local_time/Makefile
+- include/almost/boost/date_time/Makefile
+- include/almost/boost/date_time/posix_time/Makefile
+- include/almost/boost/detail/Makefile
+- include/almost/boost/dynamic_bitset/Makefile
+- include/almost/boost/filesystem/Makefile
+- include/almost/boost/format/detail/Makefile
+- include/almost/boost/format/Makefile
+- include/almost/boost/function/detail/Makefile
+- include/almost/boost/function/Makefile
+- include/almost/boost/functional/detail/Makefile
+- include/almost/boost/functional/hash/Makefile
+- include/almost/boost/functional/Makefile
+- include/almost/boost/graph/detail/Makefile
+- include/almost/boost/graph/Makefile
+- include/almost/boost/integer/Makefile
+- include/almost/boost/io/Makefile
+- include/almost/boost/iostreams/detail/adapter/Makefile
+- include/almost/boost/iostreams/detail/broken_overload_resolution/Makefile
+- include/almost/boost/iostreams/detail/config/Makefile
+- include/almost/boost/iostreams/detail/Makefile
+- include/almost/boost/iostreams/detail/streambuf/Makefile
+- include/almost/boost/iostreams/detail/vc6/Makefile
+- include/almost/boost/iostreams/device/Makefile
+- include/almost/boost/iostreams/filter/Makefile
+- include/almost/boost/iostreams/Makefile
+- include/almost/boost/iterator/detail/Makefile
+- include/almost/boost/iterator/Makefile
+- include/almost/boost/lambda/detail/Makefile
+- include/almost/boost/lambda/Makefile
+- include/almost/boost/logic/Makefile
+- include/almost/boost/Makefile
+- include/almost/boost/math/Makefile
+- include/almost/boost/math/special_functions/Makefile
+- include/almost/boost/mpl/aux_/config/Makefile
+- include/almost/boost/mpl/aux_/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/bcc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/bcc551/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/dmc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/gcc/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/msvc60/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/msvc70/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/mwcw/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/no_ttp/Makefile
+- include/almost/boost/mpl/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/aux_/preprocessor/Makefile
+- include/almost/boost/mpl/aux_/range_c/Makefile
+- include/almost/boost/mpl/aux_/test/Makefile
+- include/almost/boost/mpl/limits/Makefile
+- include/almost/boost/mpl/list/aux_/Makefile
+- include/almost/boost/mpl/list/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/list/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/list/Makefile
+- include/almost/boost/mpl/Makefile
+- include/almost/boost/mpl/map/aux_/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/map/aux_/preprocessed/typeof_based/Makefile
+- include/almost/boost/mpl/map/Makefile
+- include/almost/boost/mpl/math/Makefile
+- include/almost/boost/mpl/multiset/aux_/Makefile
+- include/almost/boost/mpl/multiset/Makefile
+- include/almost/boost/mpl/set/aux_/Makefile
+- include/almost/boost/mpl/set/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/set/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/set/Makefile
+- include/almost/boost/mpl/vector/aux_/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/no_ctps/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/plain/Makefile
+- include/almost/boost/mpl/vector/aux_/preprocessed/typeof_based/Makefile
+- include/almost/boost/mpl/vector/Makefile
+- include/almost/boost/multi_array/Makefile
+- include/almost/boost/multi_index/detail/Makefile
+- include/almost/boost/multi_index/Makefile
+- include/almost/boost/numeric/conversion/detail/Makefile
+- include/almost/boost/numeric/conversion/Makefile
+- include/almost/boost/numeric/interval/compare/Makefile
+- include/almost/boost/numeric/interval/detail/Makefile
+- include/almost/boost/numeric/interval/ext/Makefile
+- include/almost/boost/numeric/interval/Makefile
+- include/almost/boost/numeric/Makefile
+- include/almost/boost/numeric/ublas/detail/Makefile
+- include/almost/boost/numeric/ublas/Makefile
+- include/almost/boost/optional/Makefile
+- include/almost/boost/parameter/aux_/Makefile
+- include/almost/boost/parameter/Makefile
+- include/almost/boost/pending/detail/Makefile
+- include/almost/boost/pending/Makefile
+- include/almost/boost/pool/detail/Makefile
+- include/almost/boost/pool/Makefile
+- include/almost/boost/preprocessor/arithmetic/detail/Makefile
+- include/almost/boost/preprocessor/arithmetic/Makefile
+- include/almost/boost/preprocessor/array/Makefile
+- include/almost/boost/preprocessor/comparison/Makefile
+- include/almost/boost/preprocessor/config/Makefile
+- include/almost/boost/preprocessor/control/detail/dmc/Makefile
+- include/almost/boost/preprocessor/control/detail/edg/Makefile
+- include/almost/boost/preprocessor/control/detail/Makefile
+- include/almost/boost/preprocessor/control/detail/msvc/Makefile
+- include/almost/boost/preprocessor/control/Makefile
+- include/almost/boost/preprocessor/debug/Makefile
+- include/almost/boost/preprocessor/detail/dmc/Makefile
+- include/almost/boost/preprocessor/detail/Makefile
+- include/almost/boost/preprocessor/facilities/Makefile
+- include/almost/boost/preprocessor/iteration/detail/bounds/Makefile
+- include/almost/boost/preprocessor/iteration/detail/iter/Makefile
+- include/almost/boost/preprocessor/iteration/detail/Makefile
+- include/almost/boost/preprocessor/iteration/Makefile
+- include/almost/boost/preprocessor/list/detail/dmc/Makefile
+- include/almost/boost/preprocessor/list/detail/edg/Makefile
+- include/almost/boost/preprocessor/list/detail/Makefile
+- include/almost/boost/preprocessor/list/Makefile
+- include/almost/boost/preprocessor/logical/Makefile
+- include/almost/boost/preprocessor/Makefile
+- include/almost/boost/preprocessor/punctuation/Makefile
+- include/almost/boost/preprocessor/repetition/detail/dmc/Makefile
+- include/almost/boost/preprocessor/repetition/detail/edg/Makefile
+- include/almost/boost/preprocessor/repetition/detail/Makefile
+- include/almost/boost/preprocessor/repetition/detail/msvc/Makefile
+- include/almost/boost/preprocessor/repetition/Makefile
+- include/almost/boost/preprocessor/selection/Makefile
+- include/almost/boost/preprocessor/seq/detail/Makefile
+- include/almost/boost/preprocessor/seq/Makefile
+- include/almost/boost/preprocessor/slot/detail/Makefile
+- include/almost/boost/preprocessor/slot/Makefile
+- include/almost/boost/preprocessor/tuple/Makefile
+- include/almost/boost/program_options/detail/Makefile
+- include/almost/boost/program_options/Makefile
+- include/almost/boost/ptr_container/detail/Makefile
+- include/almost/boost/ptr_container/Makefile
+- include/almost/boost/python/converter/Makefile
+- include/almost/boost/python/detail/Makefile
+- include/almost/boost/python/Makefile
+- include/almost/boost/python/object/Makefile
+- include/almost/boost/python/suite/indexing/detail/Makefile
+- include/almost/boost/python/suite/indexing/Makefile
+- include/almost/boost/python/suite/Makefile
+- include/almost/boost/random/detail/Makefile
+- include/almost/boost/random/Makefile
+- include/almost/boost/range/detail/Makefile
+- include/almost/boost/range/detail/mfc/Makefile
+- include/almost/boost/range/detail/vc6/Makefile
+- include/almost/boost/range/Makefile
+- include/almost/boost/regex/config/Makefile
+- include/almost/boost/regex/Makefile
+- include/almost/boost/regex/pending/Makefile
+- include/almost/boost/regex/v4/Makefile
+- include/almost/boost/serialization/detail/Makefile
+- include/almost/boost/serialization/Makefile
+- include/almost/boost/signals/detail/Makefile
+- include/almost/boost/signals/Makefile
+- include/almost/boost/thread/detail/Makefile
+- include/almost/boost/thread/Makefile
+- include/almost/boost/tuple/detail/Makefile
+- include/almost/boost/tuple/Makefile
+- include/almost/boost/type_traits/detail/Makefile
+- include/almost/boost/type_traits/Makefile
+- include/almost/boost/utility/detail/Makefile
+- include/almost/boost/utility/Makefile
+- include/almost/boost/variant/detail/Makefile
+- include/almost/boost/variant/Makefile
+- include/almost/boost/wave/cpplexer/Makefile
+- include/almost/boost/wave/cpplexer/re2clex/Makefile
+- include/almost/boost/wave/grammars/Makefile
+- include/almost/boost/wave/Makefile
+- include/almost/boost/wave/util/Makefile
+ include/almost/boost_1_30/config/compiler/Makefile
+ include/almost/boost_1_30/config/Makefile
+ include/almost/boost_1_30/config/platform/Makefile
+@@ -441,7 +247,6 @@
+ include/almost/io/Makefile
+ include/almost/kernel/Makefile
+ include/almost/kernel/scratch/Makefile
+- include/almost/libxml/Makefile
+ include/almost/Makefile
+ include/almost/mbmd/Makefile
+ include/almost/misc/Makefile
+@@ -460,7 +265,6 @@
+ include/almost/nmr/Makefile
+ include/almost/tmd/Makefile
+ include/almost/template/Makefile
+- include/almost/tinyxml/Makefile
+ include/almost/types/Makefile
+ include/almost/zeta/Makefile
+ include/Makefile
+@@ -470,8 +274,6 @@
+ src/lib/Makefile
+ src/lib/modules/Makefile
+ src/Makefile
+- src/tinyxml/Makefile
+- src/libxml/Makefile
+ src/forcefield/Makefile
+ src/examples/Makefile
+ src/tests/Makefile
diff --git a/sci-chemistry/almost/files/gcc-4.3.patch b/sci-chemistry/almost/files/gcc-4.3.patch
index 44d06c73f..4b27ee19d 100644
--- a/sci-chemistry/almost/files/gcc-4.3.patch
+++ b/sci-chemistry/almost/files/gcc-4.3.patch
@@ -58,3 +58,13 @@
ZObj * FactoryTrampolin::bind(ZObj * o){
+--- ./src/lib/modules/shx/shxmalloc.cpp 2008-05-07 17:06:49.000000000 +0200
++++ ./src/lib/modules/shx/shxmalloc.cpp.new 2009-08-22 21:31:55.000000000 +0200
+@@ -15,6 +15,7 @@
+ ***************************************************************************/
+
+ #include <vector>
++#include <cstdlib>
+
+ using namespace std;
+