aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-12 22:03:53 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-12 22:03:53 +0200
commit592d63f17085e0b35fb96e760491795320f50d9d (patch)
tree00dbb5ea16ec4b4edb77d021b83387af283a566f /sci-chemistry/ball/ball-9999.ebuild
parentsci-libs/trilinos: Drop old, fix handling of qt support (diff)
downloadsci-592d63f17085e0b35fb96e760491795320f50d9d.tar.gz
sci-592d63f17085e0b35fb96e760491795320f50d9d.tar.bz2
sci-592d63f17085e0b35fb96e760491795320f50d9d.zip
sci-chemistry/ball: Bump EAPI and python eclass
Package-Manager: portage-2.2.0_alpha179
Diffstat (limited to 'sci-chemistry/ball/ball-9999.ebuild')
-rw-r--r--sci-chemistry/ball/ball-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-chemistry/ball/ball-9999.ebuild b/sci-chemistry/ball/ball-9999.ebuild
index 8cab0732c..d1f7750d5 100644
--- a/sci-chemistry/ball/ball-9999.ebuild
+++ b/sci-chemistry/ball/ball-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit cmake-utils git-2 python
+inherit cmake-utils git-2 python-single-r1
DESCRIPTION="Biochemical Algorithms Library"
HOMEPAGE="http://www.ball-project.org/"
@@ -36,6 +36,7 @@ RDEPEND="
cuda? ( dev-util/nvidia-cuda-toolkit )
mpi? ( virtual/mpi )
sql? ( dev-qt/qtsql )
+ python? ( ${PYTHON_DEPS} )
webkit? ( dev-qt/qtwebkit )"
DEPEND="${RDEPEND}
dev-python/sip
@@ -48,9 +49,7 @@ PATCHES=(
)
pkg_setup() {
- use python \
- && python_set_active_version 2 \
- && python_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {