aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-25 16:12:57 +0200
committerJustin Lecher <jlec@gentoo.org>2012-03-25 16:12:57 +0200
commitb17af5ac5341940c9b87e44b33f7af4b9e6adcaf (patch)
tree4ac0d0b232c64a82704b740325e8867c8a16b584 /sci-chemistry/ball/ball-9999.ebuild
parentCorrect usage of python.eclass (diff)
downloadsci-b17af5ac5341940c9b87e44b33f7af4b9e6adcaf.tar.gz
sci-b17af5ac5341940c9b87e44b33f7af4b9e6adcaf.tar.bz2
sci-b17af5ac5341940c9b87e44b33f7af4b9e6adcaf.zip
Fix patches to be in line with tree
(Portage version: 2.2.0_alpha95/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-chemistry/ball/ball-9999.ebuild')
-rw-r--r--sci-chemistry/ball/ball-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sci-chemistry/ball/ball-9999.ebuild b/sci-chemistry/ball/ball-9999.ebuild
index 168967693..4fac56b8d 100644
--- a/sci-chemistry/ball/ball-9999.ebuild
+++ b/sci-chemistry/ball/ball-9999.ebuild
@@ -42,19 +42,17 @@ DEPEND="${RDEPEND}
sys-devel/bison
virtual/yacc"
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-libsvm.patch
+ )
+
pkg_setup() {
use python \
&& python_set_active_version 2 \
&& python_pkg_setup
}
-src_prepare() {
- sed \
- -e '/INSTALL_DIRECTORY/s:"lib":${CMAKE_INSTALL_LIBDIR}:g' \
- -i CMakeLists.txt || die
- base_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_use threads FFTW_THREADS)