aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-25 13:28:39 +0200
committerJustin Lecher <jlec@gentoo.org>2012-03-25 13:28:39 +0200
commit673d558f7618947a06ea7c77970c6c877c9ccf6d (patch)
treee319c881f50fa0af6dc87d2b26d02843e2cd0262 /sci-chemistry/ball
parent[dev-cpp/eigen] Added 3.1.0_alpha2 version. Uncomplete lapack implementation. (diff)
downloadsci-673d558f7618947a06ea7c77970c6c877c9ccf6d.tar.gz
sci-673d558f7618947a06ea7c77970c6c877c9ccf6d.tar.bz2
sci-673d558f7618947a06ea7c77970c6c877c9ccf6d.zip
New addition, written by me, #406401
(Portage version: 2.2.0_alpha95/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-chemistry/ball')
-rw-r--r--sci-chemistry/ball/ChangeLog10
-rw-r--r--sci-chemistry/ball/ball-9999.ebuild62
-rw-r--r--sci-chemistry/ball/metadata.xml32
3 files changed, 104 insertions, 0 deletions
diff --git a/sci-chemistry/ball/ChangeLog b/sci-chemistry/ball/ChangeLog
new file mode 100644
index 000000000..c93b22c3c
--- /dev/null
+++ b/sci-chemistry/ball/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/ball
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ball-9999 (25 Mar 2012)
+
+ 25 Mar 2012; Justin Lecher <jlec@gentoo.org> +ball-9999.ebuild,
+ +metadata.xml:
+ New addition, written by me, #406401
+
diff --git a/sci-chemistry/ball/ball-9999.ebuild b/sci-chemistry/ball/ball-9999.ebuild
new file mode 100644
index 000000000..fc7306d67
--- /dev/null
+++ b/sci-chemistry/ball/ball-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+
+inherit cmake-utils git-2 python
+
+DESCRIPTION="Biochemical Algorithms Library"
+HOMEPAGE="http://www.ball-project.org/"
+SRC_URI=""
+EGIT_REPO_URI="http://ball-git.bioinf.uni-sb.de/BALL.git"
+
+SLOT="0"
+LICENSE="LGPL-2 GPL-3"
+KEYWORDS=""
+IUSE="cuda mpi +python sql +threads +webkit"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost
+ media-libs/glew
+ sci-libs/fftw:3.0[threads?]
+ sci-libs/gsl
+ sci-libs/libsvm
+ sci-mathematics/lpsolve
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-opengl
+ x11-libs/qt-test
+ x11-libs/qt-webkit
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )
+ sql? ( x11-libs/qt-sql )
+ webkit? ( x11-libs/qt-webkit )"
+DEPEND="${RDEPEND}
+ dev-python/sip
+ sys-devel/bison
+ virtual/yacc"
+
+src_prepare() {
+ sed \
+ -e '/INSTALL_DIRECTORY/s:"lib":${CMAKE_INSTALL_LIBDIR}:g' \
+ -i CMakeLists.txt || die
+ base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use threads FFTW_THREADS)
+ $(cmake-utils_use cuda MT_ENABLE_CUDA)
+ $(cmake-utils_use mpi MT_ENABLE_MPI)
+ $(cmake-utils_use sql BALL_HAS_QTSQL)
+ $(cmake-utils_use_use webkit USE_QTWEBKIT)
+ $(cmake-utils_use python BALL_PYTHON_SUPPORT)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-chemistry/ball/metadata.xml b/sci-chemistry/ball/metadata.xml
new file mode 100644
index 000000000..8c954a23a
--- /dev/null
+++ b/sci-chemistry/ball/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Rapid Software Prototyping can significantly reduce development times in the
+field of Computational Molecular Biology and Molecular Modeling.
+BALL (Biochemical Algorithms Library) is an application framework in C++ that
+has been specifically designed for this purpose. It provides an extensive set
+of data structures as well as classes for Molecular Mechanics, advanced
+solvation methods, comparison and analysis of protein structures, file
+import/export, and visualization .
+
+BALL has been carefully designed to be robust, easy to use, and open to
+extensions. Especially its extensibility which results from an object-oriented
+and generic programming approach distinguishes it from other software packages.
+BALL is well suited to serve as a public repository for reliable data
+structures and algorithms.
+
+Based on BALL we have developed a stand-alone tool for molecular visualization,
+BALLView . BALLView makes the broad functionality available through an
+integrated user-friendly GUI.
+</longdescription>
+ <use>
+ <flag name="sql">Include SQL database support</flag>
+ <flag name="cuda">Include cuda support</flag>
+ <flag name="webkit">Uses <pkg>x11-libs/qt-webkit</pkg> for drawing</flag>
+ </use>
+</pkgmetadata>