aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-11 15:52:44 +0100
committerJustin Lecher <jlec@gentoo.org>2013-03-11 15:52:44 +0100
commit4d53496fb20e2d451e646d2de89c2f316a8c8045 (patch)
tree57c1d41f0c78a4b088b79f2def91eda490bd3d2a /sci-chemistry/concoord/concoord-2.1.2.ebuild
parentadded cuda build fix from gx86 (diff)
downloadsci-4d53496fb20e2d451e646d2de89c2f316a8c8045.tar.gz
sci-4d53496fb20e2d451e646d2de89c2f316a8c8045.tar.bz2
sci-4d53496fb20e2d451e646d2de89c2f316a8c8045.zip
sci-chemistry/concoord: Version Bump; switch license to all-rights-reserved
Package-Manager: portage-2.2.0_alpha166
Diffstat (limited to 'sci-chemistry/concoord/concoord-2.1.2.ebuild')
-rw-r--r--sci-chemistry/concoord/concoord-2.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/concoord/concoord-2.1.2.ebuild b/sci-chemistry/concoord/concoord-2.1.2.ebuild
new file mode 100644
index 000000000..b36801f0d
--- /dev/null
+++ b/sci-chemistry/concoord/concoord-2.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Method to generate protein conformations around a known structure based on geometric restrictions"
+HOMEPAGE="http://www.mpibpc.mpg.de/groups/de_groot/concoord/concoord.html"
+SRC_URI="
+ amd64? ( http://www3.mpibpc.mpg.de/groups/de_groot/${PN}/${PN}_${PV}_linux64.tgz )
+ x86? ( http://www3.mpibpc.mpg.de/groups/de_groot/${PN}/${PN}_${PV}_linux32.tgz )"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+QA_PREBUILT="opt/${PN}/bin/*"
+
+S="${WORKDIR}"/${PN}_${PV}
+
+src_install() {
+ insinto /opt/${PN}/
+ doins -r lib
+ exeinto /opt/${PN}/bin
+ doexe bin/*
+ cat >> "${T}"/60${PN} <<- EOF
+ CONCOORDLIB="${EPREFIX}/opt/${PN}/lib"
+ CONCOORDBIN="${EPREFIX}/opt/${PN}/bin"
+ PATH="${EPREFIX}/opt/${PN}/bin"
+ EOF
+ doenvd "${T}"/60${PN}
+}