aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-17 10:36:39 +0100
committerJustin Lecher <jlec@gentoo.org>2012-01-17 10:36:39 +0100
commitc5e4bed5f14db1b73bff0b47ca762f6e7f0efc84 (patch)
treea68ce03ad182068bcffdb8a92b270ff1196d0bb4 /sci-chemistry/concoord/concoord-2.1.ebuild
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-c5e4bed5f14db1b73bff0b47ca762f6e7f0efc84.tar.gz
sci-c5e4bed5f14db1b73bff0b47ca762f6e7f0efc84.tar.bz2
sci-c5e4bed5f14db1b73bff0b47ca762f6e7f0efc84.zip
New addition
(Portage version: 2.2.0_alpha84/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-chemistry/concoord/concoord-2.1.ebuild')
-rw-r--r--sci-chemistry/concoord/concoord-2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/concoord/concoord-2.1.ebuild b/sci-chemistry/concoord/concoord-2.1.ebuild
new file mode 100644
index 000000000..22c215560
--- /dev/null
+++ b/sci-chemistry/concoord/concoord-2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Method to generate protein conformations around a known structure based on geometric restrictions"
+HOMEPAGE="http://www.mpibpc.mpg.de/groups/de_groot/concoord/concoord.html"
+SRC_URI="
+ amd64? ( http://www.mpibpc.mpg.de/groups/de_groot/concoord/concoord2.1_linux_x86_64.tgz )
+ x86? ( http://www.mpibpc.mpg.de/groups/de_groot/concoord/concoord2.1_linux_i386.tgz )"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="as-is"
+IUSE=""
+
+QA_DT_HASH="opt/${PN}/bin/.*"
+
+S="${WORKDIR}"/${PN}${PV}
+
+src_install() {
+ insinto /opt/${PN}/
+ rm lib/*.a || die
+ doins -r lib
+ exeinto /opt/${PN}/bin
+ doexe bin/*
+ cat >> "${T}"/60${PN} <<- EOF
+ CONCOORDLIB="${EPREFIX}/opt/${PN}/lib"
+ CONCOORDBIN="${EPREFIX}/opt/${PN}/bin"
+ PATH="${EPREFIX}/opt/${PN}/bin"
+ EOF
+ doenvd "${T}"/60${PN}
+}