aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2013-09-20 14:48:51 -0600
committerNicolas Bock <nicolasbock@gmail.com>2013-09-20 14:48:51 -0600
commit0d9632ae61b09744fc07b3022c69d543ee76cb20 (patch)
treea5e86a0da182c02f0d85fcdcadb5f935b6e1b4ba /sci-chemistry/freeon/freeon-1.0.3.ebuild
parentsci-chemistry/coot: Clean for latest HEAD (diff)
downloadsci-0d9632ae61b09744fc07b3022c69d543ee76cb20.tar.gz
sci-0d9632ae61b09744fc07b3022c69d543ee76cb20.tar.bz2
sci-0d9632ae61b09744fc07b3022c69d543ee76cb20.zip
sci-chemistry/freeon-1.0.3: Version bump.
Package-Manager: portage-2.2.1
Diffstat (limited to 'sci-chemistry/freeon/freeon-1.0.3.ebuild')
-rw-r--r--sci-chemistry/freeon/freeon-1.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/freeon/freeon-1.0.3.ebuild b/sci-chemistry/freeon/freeon-1.0.3.ebuild
new file mode 100644
index 000000000..ecbbe3762
--- /dev/null
+++ b/sci-chemistry/freeon/freeon-1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="An experimental suite of programs for linear scaling quantum chemistry."
+HOMEPAGE="http://www.freeon.org"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="standalone-BCSR static-libs"
+
+RDEPEND="
+ sci-libs/hdf5
+ virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable standalone-BCSR)
+}