aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2013-09-14 12:10:09 -0600
committerNicolas Bock <nicolasbock@gmail.com>2013-09-14 12:10:09 -0600
commite66f3f8595a4a945ccb50ec13725a4076d926f70 (patch)
tree796f177d341373b4f3d3c5803e65af448c1395b7 /sci-chemistry/freeon/freeon-20130912.ebuild
parentadded STFC license (diff)
downloadsci-e66f3f8595a4a945ccb50ec13725a4076d926f70.tar.gz
sci-e66f3f8595a4a945ccb50ec13725a4076d926f70.tar.bz2
sci-e66f3f8595a4a945ccb50ec13725a4076d926f70.zip
sci-chemistry/freeon-20130912: Added new version.
Package-Manager: portage-2.2.1
Diffstat (limited to 'sci-chemistry/freeon/freeon-20130912.ebuild')
-rw-r--r--sci-chemistry/freeon/freeon-20130912.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/freeon/freeon-20130912.ebuild b/sci-chemistry/freeon/freeon-20130912.ebuild
new file mode 100644
index 000000000..956c7662b
--- /dev/null
+++ b/sci-chemistry/freeon/freeon-20130912.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="an experimental suite of programs for linear scaling quantum chemistry."
+HOMEPAGE="http://www.freeon.org"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ sci-libs/hdf5
+ virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-lapacklibs="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ #TODO mv BasisSets from /usr to /usr/share/freeon/
+ autotools-utils_src_configure
+}