aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-18 09:58:51 +0200
committerJustin Lecher <jlec@gentoo.org>2013-07-18 09:59:53 +0200
commite43bc78a3806353951cca10d87dc107849b5a06f (patch)
tree62dc89f42a967e36d9e62b5a3b8e5f18395bb275 /sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild
parentmoved AUTOTOOLS_BUILD_DIR -> BUILD_DIR (diff)
downloadsci-e43bc78a3806353951cca10d87dc107849b5a06f.tar.gz
sci-e43bc78a3806353951cca10d87dc107849b5a06f.tar.bz2
sci-e43bc78a3806353951cca10d87dc107849b5a06f.zip
sci-chemistry/gnome-chemistry-utils: Drop unneeded patch and fix goffice dep
Package-Manager: portage-2.2.0_alpha188 RepoMan-Options: --force
Diffstat (limited to 'sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild')
-rw-r--r--sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild
new file mode 100644
index 000000000..866888640
--- /dev/null
+++ b/sci-chemistry/gnome-chemistry-utils/gnome-chemistry-utils-0.14.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+inherit eutils gnome2 versionator
+
+DESCRIPTION="Programs and library containing GTK widgets and C++ classes related to chemistry"
+HOMEPAGE="http://gchemutils.nongnu.org/"
+SRC_URI="http://download.savannah.gnu.org/releases/gchemutils/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3 FDL-1.3"
+IUSE="gnumeric nls"
+
+RDEPEND="
+ >=dev-libs/glib-2.26.0:2
+ >=dev-libs/libxml2-2.4.16:2
+ >=gnome-extra/libgsf-1.14.9
+ >=sci-chemistry/bodr-5
+ >=sci-chemistry/chemical-mime-data-0.1.94
+ >=sci-chemistry/openbabel-2.3.0
+ >=x11-libs/cairo-1.6.0
+ >=x11-libs/gdk-pixbuf-2.22.0
+ >=x11-libs/goffice-0.10.4
+ x11-libs/gtk+:3
+ >=x11-libs/libX11-1.0.0
+ gnumeric? ( >=app-office/gnumeric-1.11.6 )"
+DEPEND="
+ virtual/pkgconfig
+ app-doc/doxygen"
+
+RESTRICT="mirror"
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ --disable-mozilla-plugin
+ --disable-update-databases
+ )
+ gnome2_src_configure ${myeconfargs[@]}
+}