aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-05-01 17:13:35 +0200
committerChristoph Junghans <ottxor@gentoo.org>2011-05-01 17:13:35 +0200
commit726d5118d71546b6c8a190ad39b179ca39fdeced (patch)
treeda0a992b752195be3594726f0759a75009055da9 /sci-chemistry/gromacs/gromacs-4.5.9999.ebuild
parentMore zfs updates (diff)
downloadsci-726d5118d71546b6c8a190ad39b179ca39fdeced.tar.gz
sci-726d5118d71546b6c8a190ad39b179ca39fdeced.tar.bz2
sci-726d5118d71546b6c8a190ad39b179ca39fdeced.zip
[sci-chemistry/gromacs] sync with tree
(Portage version: 2.1.9.42/git/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-4.5.9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.9999.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/sci-chemistry/gromacs/gromacs-4.5.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.5.9999.ebuild
index 8d3c8f813..469f60402 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.9999.ebuild
@@ -2,17 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI="4"
LIBTOOLIZE="true"
TEST_PV="4.0.4"
-MANUAL_PV="4.5.3"
+MANUAL_PV="4.5.4"
inherit autotools-utils bash-completion flag-o-matic multilib toolchain-funcs
SRC_URI="test? ( ftp://ftp.gromacs.org/pub/tests/gmxtest-${TEST_PV}.tgz )
- doc? (
- http://www.gromacs.org/@api/deki/files/133/=manual-${MANUAL_PV}.pdf -> gromacs-manual-${MANUAL_PV}.pdf )"
+ doc? ( ftp://ftp.gromacs.org/pub/manual/manual-${MANUAL_PV}.pdf -> gromacs-manual-${MANUAL_PV}.pdf )"
if [ "${PV%9999}" != "${PV}" ]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs"
@@ -29,7 +28,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="X altivec blas dmalloc doc -double-precision +fftw fkernels +gsl lapack
-mpi +single-precision sse sse2 static-libs test +threads +xml zsh-completion"
+mpi +single-precision sse2 static-libs test +threads +xml zsh-completion"
+REQUIRED_USE="fkernels? ( !threads )"
CDEPEND="
X? (
@@ -51,10 +51,6 @@ RDEPEND="${CDEPEND}
RESTRICT="test"
-#gromacs has gnu exec stacks for speedup
-QA_EXECSTACK="usr/lib/libgmx.so.*
- usr/lib/libgmx_d.so.*"
-
src_prepare() {
if use mpi && use threads; then
elog "mdrun uses only threads OR mpi, and gromacs favours the"
@@ -96,10 +92,8 @@ src_configure() {
#note for gentoo-PREFIX on apple: use --enable-apple-64bit
- #fortran will gone in gromacs 5.0 anyway
#note for gentoo-PREFIX on aix, fortran (xlf) is still much faster
if use fkernels; then
- use threads && eerror "You cannot compile fortran kernel with threads"
ewarn "Fortran kernels are usually not faster than C kernels and assembly"
ewarn "I hope, you know what are you doing..."
fi
@@ -126,22 +120,19 @@ src_configure() {
fi
# if we need external blas or lapack
- use blas && export LIBS+=" $(pkg-config blas cblas --libs)"
+ use blas && export LIBS+=" $(pkg-config blas --libs)"
use lapack && export LIBS+=" $(pkg-config lapack --libs)"
local sseflag="x86-64-sse"
use x86 && sseflag="ia32-sse"
- #a bug in gromacs autotools
- use sse && append-flags -msse
+ #missing flag in autotools (bug #339837)
use sse2 && append-flags -msse2
for x in ${GMX_DIRS}; do
- local suffix="" sse="sse"
+ local suffix=""
#if we build single and double - double is suffixed
use double-precision && use single-precision && \
[ "${x}" = "double" ] && suffix="_d"
- #double uses sse2, single sse
- [ "${x}" = "double" ] && sse="sse2"
myeconfargs=(
--bindir="${EPREFIX}"/usr/bin
--docdir="${EPREFIX}"/usr/share/doc/"${PF}"
@@ -162,7 +153,7 @@ src_configure() {
--disable-power6
--disable-ia32-sse
--disable-x86-64-sse
- $(use_enable $sse $sseflag)
+ $(use_enable sse2 $sseflag)
)
#disable ia32-sse and x86-64-sse and enable what we really need in last line