aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-04 09:05:34 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-09-04 09:05:34 -0600
commite1bd57c95dd8f13b3e2fea99dec893f853decdbc (patch)
treec48531f6a9d3ce64936ef6875b4c8915819518af /sci-chemistry/gromacs/gromacs-5.0.9999.ebuild
parentdrop old (diff)
downloadsci-e1bd57c95dd8f13b3e2fea99dec893f853decdbc.tar.gz
sci-e1bd57c95dd8f13b3e2fea99dec893f853decdbc.tar.bz2
sci-e1bd57c95dd8f13b3e2fea99dec893f853decdbc.zip
sync with gx86
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-5.0.9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-5.0.9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-chemistry/gromacs/gromacs-5.0.9999.ebuild b/sci-chemistry/gromacs/gromacs-5.0.9999.ebuild
index 92152a345..042eb28d2 100644
--- a/sci-chemistry/gromacs/gromacs-5.0.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-5.0.9999.ebuild
@@ -21,7 +21,7 @@ if [[ $PV = *9999* ]]; then
else
SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${PN}-${PV/_/-}.tar.gz
test? ( http://gerrit.gromacs.org/download/regressiontests-${TEST_PV}.tar.gz )"
- KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
fi
ACCE_IUSE="sse2 sse4_1 avx_128_fma avx_256 avx2_256"
@@ -189,6 +189,8 @@ src_configure() {
-DGMX_LIBS_SUFFIX="${suffix}"
)
BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ [[ ${CHOST} != *-darwin* ]] || \
+ sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
mycmakeargs=(
@@ -203,6 +205,8 @@ src_configure() {
-DGMX_LIBS_SUFFIX="_mpi${suffix}"
)
BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
+ [[ ${CHOST} != *-darwin* ]] || \
+ sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}_mpi/gentoo_rules.cmake" || die
done
}