aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 17:01:44 +0100
committerJustin Lecher <jlec@gentoo.org>2010-12-16 17:01:44 +0100
commit920d8070ba53179d136a693c389db35285b6061f (patch)
tree08f9c0c0bd244b246f3b168734883dc1684ef8b1 /sci-chemistry/gromacs/gromacs-9999.ebuild
parentagain (diff)
downloadsci-920d8070ba53179d136a693c389db35285b6061f.tar.gz
sci-920d8070ba53179d136a693c389db35285b6061f.tar.bz2
sci-920d8070ba53179d136a693c389db35285b6061f.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 54b6d839a..55d0ddc70 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -10,7 +10,7 @@ TEST_PV="4.0.4"
EGIT_REPO_URI="git://git.gromacs.org/gromacs"
EGIT_BRANCH="master"
-inherit autotools bash-completion eutils fortran git multilib toolchain-funcs
+inherit autotools bash-completion eutils git multilib toolchain-funcs
DESCRIPTION="The ultimate molecular dynamics simulation package"
HOMEPAGE="http://www.gromacs.org/"
@@ -43,15 +43,6 @@ QA_EXECSTACK="usr/lib/libgmx.so.*
use static && QA_EXECSTACK="$QA_EXECSTACK usr/bin/*"
-pkg_setup() {
- if use fkernels; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- else
- FORTRANC=""
- fi
-}
-
src_prepare() {
( use single-precision || use double-precision ) || \
@@ -187,10 +178,10 @@ src_configure() {
einfo "Configuring for ${x} precision"
cd "${S}-${x}"
local p=myconf${x}
- ECONF_SOURCE="${S}" econf ${!p} --disable-mpi CC="$(tc-getCC)" F77="${FORTRANC}"
+ ECONF_SOURCE="${S}" econf ${!p} --disable-mpi CC="$(tc-getCC)" F77="$(tc-getFC)"
use mpi || continue
cd "${S}-${x}_mpi"
- ECONF_SOURCE="${S}" econf ${!p} --enable-mpi CC="$(tc-getCC)" F77="${FORTRANC}"
+ ECONF_SOURCE="${S}" econf ${!p} --enable-mpi CC="$(tc-getCC)" F77="$(tc-getFC)"
done
}