aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-12-06 13:34:20 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2013-12-06 13:34:20 +0400
commit48ddd384fe8e96a4e904b8ccb1da1fc86087b1e3 (patch)
treee2caf908ab30974b6c744ad5c69edd3a9bac2fe4 /sci-chemistry/gromacs
parentapp-doc/root-docs: version bump (diff)
downloadsci-48ddd384fe8e96a4e904b8ccb1da1fc86087b1e3.tar.gz
sci-48ddd384fe8e96a4e904b8ccb1da1fc86087b1e3.tar.bz2
sci-48ddd384fe8e96a4e904b8ccb1da1fc86087b1e3.zip
Add 5.0-beta1 release
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog6
-rw-r--r--sci-chemistry/gromacs/Manifest2
-rw-r--r--sci-chemistry/gromacs/gromacs-5.0_beta1.ebuild258
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild13
4 files changed, 271 insertions, 8 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 781b35426..4c5ac13af 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*gromacs-5.0_beta1 (06 Dec 2013)
+
+ 06 Dec 2013; Alexey Shvetsov <alexxy@gentoo.org> +gromacs-5.0_beta1.ebuild,
+ gromacs-9999.ebuild:
+ Add 5.0-beta1 release
+
05 Dec 2013; Alexey Shvetsov <alexxy@gentoo.org> gromacs-9999.ebuild:
Make gromacs 9999 build manual again
diff --git a/sci-chemistry/gromacs/Manifest b/sci-chemistry/gromacs/Manifest
new file mode 100644
index 000000000..a076f19ae
--- /dev/null
+++ b/sci-chemistry/gromacs/Manifest
@@ -0,0 +1,2 @@
+DIST gromacs-5.0-beta1.tar.gz 18849424 SHA256 c663d570302e7cc91cf732b356fbaa4b39fd8a527927ca4ca13f35797f1ee88b SHA512 86ad4a9169ddb78308f3036c880281ccb0e53f459226d4b66d1175d4e5deb05da772988b981baae2cc3e6468afbc31b5a9bff54b2bd0a3ce326a61f360a01e5c WHIRLPOOL 364c45ef77868b2fd13a1c4b49c287cdb5d4883077b63a70de23f82e178a688ed3aa6cf95d4c4fa2fd7d283c8f03dc04a9442dc28663fd170d044933c4b54128
+DIST regressiontests-5.0-beta1.tar.gz 44826977 SHA256 da629f5fbdf0c1a72c964d1af7709895ce243bb5563b64a34664c6c9006ff2ae SHA512 cd69a4fc78291f6ae21a19e3ff20bac74f79d4b4b78831a6cad6868f9974120739fa3f34b7d3d8f99b93464e19705b45727719cd8aa59f60eb2d86b39c1d5990 WHIRLPOOL 557c71de47c7a4507ba33f198c7954f77460995f4f62e737de6f376a859a7819289ae227434e0cd7501873a5bd4b35f76aa7a7e24fc966d957c727e848743f17
diff --git a/sci-chemistry/gromacs/gromacs-5.0_beta1.ebuild b/sci-chemistry/gromacs/gromacs-5.0_beta1.ebuild
new file mode 100644
index 000000000..81ed0ccde
--- /dev/null
+++ b/sci-chemistry/gromacs/gromacs-5.0_beta1.ebuild
@@ -0,0 +1,258 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+TEST_PV="5.0-beta1"
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo toolchain-funcs
+
+if [[ $PV = *9999* ]]; then
+ EGIT_REPO_URI="git://git.gromacs.org/gromacs.git
+ https://gerrit.gromacs.org/gromacs.git
+ git://github.com/gromacs/gromacs.git
+ http://repo.or.cz/r/gromacs.git"
+ EGIT_BRANCH="master"
+ inherit git-2
+else
+ SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${PN}-${PV/_/-}.tar.gz
+ test? ( http://${PN}.googlecode.com/files/regressiontests-${TEST_PV}.tar.gz )"
+fi
+
+ACCE_IUSE="sse2 sse4_1 avx128fma avx256"
+
+DESCRIPTION="The ultimate molecular dynamics simulation package"
+HOMEPAGE="http://www.gromacs.org/"
+
+# see COPYING for details
+# http://repo.or.cz/w/gromacs.git/blob/HEAD:/COPYING
+# base, vmd plugins, fftpack from numpy, blas/lapck from netlib, memtestG80 library, mpi_thread lib
+LICENSE="LGPL-2.1 UoI-NCSA !mkl? ( !fftw? ( BSD ) !blas? ( BSD ) !lapack? ( BSD ) ) cuda? ( LGPL-3 ) threads? ( BSD )"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="X blas cuda +doc -double-precision +fftw gsl lapack mkl mpi +offensive openmp +single-precision test +threads zsh-completion ${ACCE_IUSE}"
+
+CDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ blas? ( virtual/blas )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ gsl? ( sci-libs/gsl )
+ lapack? ( virtual/lapack )
+ mkl? ( sci-libs/mkl )
+ mpi? ( virtual/mpi )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ media-gfx/imagemagick
+ )"
+RDEPEND="${CDEPEND}"
+
+REQUIRED_USE="
+ || ( single-precision double-precision )
+ cuda? ( single-precision )
+ mkl? ( !blas !fftw !lapack )"
+
+DOCS=( AUTHORS README )
+
+if [[ ${PV} != *9999 ]]; then
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+pkg_pretend() {
+ [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
+ use openmp && ! tc-has-openmp && \
+ die "Please switch to an openmp compatible compiler"
+}
+
+src_unpack() {
+ if [[ ${PV} != *9999 ]]; then
+ default
+ else
+ git-2_src_unpack
+ if use test; then
+ EGIT_REPO_URI="git://git.gromacs.org/regressiontests.git" \
+ EGIT_BRANCH="master" EGIT_NOUNPACK="yes" EGIT_COMMIT="master" \
+ EGIT_SOURCEDIR="${WORKDIR}/regressiontests"\
+ git-2_src_unpack
+ fi
+ fi
+}
+
+src_prepare() {
+ #notes/todos
+ # -on apple: there is framework support
+
+ cmake-utils_src_prepare
+
+ use cuda && cuda_src_prepare
+
+ GMX_DIRS=""
+ use single-precision && GMX_DIRS+=" float"
+ use double-precision && GMX_DIRS+=" double"
+
+ if use test; then
+ for x in ${GMX_DIRS}; do
+ mkdir -p "${WORKDIR}/${P}_${x}" || die
+ cp -al "${WORKDIR}/regressiontests"* "${WORKDIR}/${P}_${x}/tests" || die
+ done
+ fi
+
+ DOC_CONTENTS="Gromacs can use sci-chemistry/vmd to read additional file formats"
+}
+
+src_configure() {
+ local mycmakeargs_pre=( ) extra fft_opts=( )
+
+ #go from slowest to fastest acceleration
+ local acce="None"
+ use sse2 && acce="SSE2"
+ use sse4_1 && acce="SSE4.1"
+ use avx128fma && acce="AVX_128_FMA"
+ use avx256 && acce="AVX_256"
+
+ #to create man pages, build tree binaries are executed (bug #398437)
+ [[ ${CHOST} = *-darwin* ]] && \
+ extra+=" -DCMAKE_BUILD_WITH_INSTALL_RPATH=OFF"
+
+ if use fftw; then
+ fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
+ elif use mkl && has_version "=sci-libs/mkl-10*"; then
+ fft_opts=( -DGMX_FFT_LIBRARY=mkl
+ -DMKL_INCLUDE_DIR="${MKLROOT}/include"
+ -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
+ )
+ elif use mkl; then
+ local bits=$(get_libdir)
+ fft_opts=( -DGMX_FFT_LIBRARY=mkl
+ -DMKL_INCLUDE_DIR="$(echo /opt/intel/*/mkl/include)"
+ -DMKL_LIBRARIES="$(echo /opt/intel/*/mkl/lib/*${bits/lib}/libmkl_rt.so)"
+ )
+ else
+ fft_opts=( -DGMX_FFT_LIBRARY=fftpack )
+ fi
+
+ mycmakeargs_pre+=(
+ "${fft_opts[@]}"
+ $(cmake-utils_use X GMX_X11)
+ $(cmake-utils_use blas GMX_EXTERNAL_BLAS)
+ $(cmake-utils_use gsl GMX_GSL)
+ $(cmake-utils_use lapack GMX_EXTERNAL_LAPACK)
+ $(cmake-utils_use openmp GMX_OPENMP)
+ $(cmake-utils_use offensive GMX_COOL_QUOTES)
+ $(cmake-utils_use doc GMX_BUILD_MANUAL)
+ -DGMX_DEFAULT_SUFFIX=off
+ -DGMX_ACCELERATION="$acce"
+ -DGMXLIB="$(get_libdir)"
+ -DGMX_VMD_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/vmd/plugins/*/molfile/"
+ -DGMX_PREFIX_LIBMD=ON
+ -DGMX_X86_AVX_GCC_MASKLOAD_BUG=OFF
+ -DGMX_USE_GCC44_BUG_WORKAROUND=OFF
+ -DBUILD_TESTING=OFF
+ -DGMX_BUILD_UNITTESTS=OFF
+ ${extra}
+ )
+
+ for x in ${GMX_DIRS}; do
+ einfo "Configuring for ${x} precision"
+ local suffix=""
+ #if we build single and double - double is suffixed
+ use double-precision && use single-precision && \
+ [[ ${x} = "double" ]] && suffix="_d"
+ local p
+ [[ ${x} = "double" ]] && p="-DGMX_DOUBLE=ON" || p="-DGMX_DOUBLE=OFF"
+ local cuda=( "-DGMX_GPU=OFF" )
+ [[ ${x} = "float" ]] && use cuda && \
+ cuda=( -DGMX_GPU=ON )
+ mycmakeargs=(
+ ${mycmakeargs_pre[@]} ${p}
+ -DGMX_MPI=OFF
+ $(cmake-utils_use threads GMX_THREAD_MPI)
+ "${cuda[@]}"
+ -DGMX_OPENMM=OFF
+ "$(use test && echo -DREGRESSIONTEST_PATH="${WORKDIR}/${P}_${x}/tests")"
+ -DGMX_BINARY_SUFFIX="${suffix}"
+ -DGMX_LIBS_SUFFIX="${suffix}"
+ )
+ BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ use mpi || continue
+ einfo "Configuring for ${x} precision with mpi"
+ mycmakeargs=(
+ ${mycmakeargs_pre[@]} ${p}
+ -DGMX_THREAD_MPI=OFF
+ -DGMX_MPI=ON ${cuda}
+ -DGMX_OPENMM=OFF
+ -DGMX_BUILD_MDRUN_ONLY=ON
+ -DGMX_BUILD_MANUAL=OFF
+ -DGMX_BINARY_SUFFIX="_mpi${suffix}"
+ -DGMX_LIBS_SUFFIX="_mpi${suffix}"
+ )
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
+ done
+}
+
+src_compile() {
+ for x in ${GMX_DIRS}; do
+ einfo "Compiling for ${x} precision"
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ cmake-utils_src_compile
+ if use doc; then
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ cmake-utils_src_compile manual
+ fi
+ use mpi || continue
+ einfo "Compiling for ${x} precision with mpi"
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
+ cmake-utils_src_compile
+ done
+}
+
+src_test() {
+ for x in ${GMX_DIRS}; do
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ cmake-utils_src_make check
+ done
+}
+
+src_install() {
+ for x in ${GMX_DIRS}; do
+ BUILD_DIR="${WORKDIR}/${P}_${x}" \
+ cmake-utils_src_install
+ if use doc; then
+ newdoc "${WORKDIR}/${P}_${x}"/manual/gromacs.pdf "${PN}-manual-${PV}.pdf"
+ fi
+ use mpi || continue
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
+ cmake-utils_src_install
+ done
+
+ newbashcomp "${ED}"/usr/bin/completion.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins "${ED}"/usr/bin/completion.zsh _${PN}
+ fi
+ rm -f "${ED}"usr/bin/completion.*
+ rm -f "${ED}"usr/bin/g_options*
+ rm -f "${ED}"usr/bin/GMXRC*
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
+ einfo "http://dx.doi.org/10.1021/ct700301q"
+ einfo
+ readme.gentoo_print_elog
+}
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 20a16c65c..81ed0ccde 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -5,7 +5,6 @@
EAPI=5
TEST_PV="5.0-beta1"
-MANUAL_PV="5.0-beta1"
CMAKE_MAKEFILE_GENERATOR="ninja"
@@ -19,8 +18,7 @@ if [[ $PV = *9999* ]]; then
EGIT_BRANCH="master"
inherit git-2
else
- SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${P}.tar.gz
- doc? ( ftp://ftp.gromacs.org/pub/manual/manual-${MANUAL_PV}.pdf -> ${PN}-manual-${MANUAL_PV}.pdf )
+ SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${PN}-${PV/_/-}.tar.gz
test? ( http://${PN}.googlecode.com/files/regressiontests-${TEST_PV}.tar.gz )"
fi
@@ -67,6 +65,10 @@ REQUIRED_USE="
DOCS=( AUTHORS README )
+if [[ ${PV} != *9999 ]]; then
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
pkg_pretend() {
[[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
use openmp && ! tc-has-openmp && \
@@ -251,11 +253,6 @@ pkg_postinst() {
einfo "Please read and cite:"
einfo "Gromacs 4, J. Chem. Theory Comput. 4, 435 (2008). "
einfo "http://dx.doi.org/10.1021/ct700301q"
- if use offensive; then
- einfo
- einfo $(g_luck)
- einfo "For more Gromacs cool quotes (gcq) add g_luck to your .bashrc"
- fi
einfo
readme.gentoo_print_elog
}