aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-29 23:15:02 +0100
committerJustin Lecher <jlec@gentoo.org>2012-11-29 23:15:02 +0100
commit7088b6dcb42f01c1121f4c0eda4830b24e77d790 (patch)
tree153a32a1a8ad4ea5e8451a0a09fe8f4d67f4f94c /sci-chemistry/mddnmr
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-7088b6dcb42f01c1121f4c0eda4830b24e77d790.tar.gz
sci-7088b6dcb42f01c1121f4c0eda4830b24e77d790.tar.bz2
sci-7088b6dcb42f01c1121f4c0eda4830b24e77d790.zip
sci-chemistry/mddnmr: Version BUmp
Package-Manager: portage-2.2.0_alpha142
Diffstat (limited to 'sci-chemistry/mddnmr')
-rw-r--r--sci-chemistry/mddnmr/ChangeLog5
-rw-r--r--sci-chemistry/mddnmr/Manifest1
-rw-r--r--sci-chemistry/mddnmr/mddnmr-2.2.ebuild59
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-chemistry/mddnmr/ChangeLog b/sci-chemistry/mddnmr/ChangeLog
index 8d5ec0500..3c1f05a71 100644
--- a/sci-chemistry/mddnmr/ChangeLog
+++ b/sci-chemistry/mddnmr/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mddnmr-2.2 (29 Nov 2012)
+
+ 29 Nov 2012; Justin Lecher <jlec@gentoo.org> +mddnmr-2.2.ebuild:
+ Version BUmp
+
*mddnmr-2.1 (28 Nov 2012)
28 Nov 2012; Justin Lecher <jlec@gentoo.org> -mddnmr-1.6.ebuild,
diff --git a/sci-chemistry/mddnmr/Manifest b/sci-chemistry/mddnmr/Manifest
index d64277642..ed4cbb469 100644
--- a/sci-chemistry/mddnmr/Manifest
+++ b/sci-chemistry/mddnmr/Manifest
@@ -1 +1,2 @@
DIST mddnmr2.1_24Sep2012.tgz 20309740 SHA256 fca7ee0c4f742bc20cdcb757f9d2c0036e7c8d7c9dee257d90a71e040207e9ab SHA512 9e906f30d90181b628681956e122c6bcdd5926602233e51e721da3de2e4e75d22d036bda8c00f25efec1c7b6c50785027153f83494f60d075e4f54e0759a8d60 WHIRLPOOL ee205ab70b78b107d2f67840e8a7dbcafda39b103e032f348d46f54d950dd1e8cd91ae92da0ef3fa5699623c3d5c01903cd694265422b23841816d909e118071
+DIST mddnmr2.2.tgz 20479366 SHA256 1f4ff1999999fc7c3469822f793d28090c00307985ada68f0e94f21c2f5e06ef SHA512 39d91efd0f5730262d2df60502269fa46121f03acc9500442aa5c36591e807904df1d6e6c944eda8fe3280aa4eaabf7d8b26a7ab0a0a54ead1483ef9147bc522 WHIRLPOOL 84e34afaaccf4c9024cb651f21df30b975268e62971d9aa1246cbdb88fd8957b997cbeab7ed2a94e49e5aba179e002f31bf7e221135b5a0a840dbd307022de6d
diff --git a/sci-chemistry/mddnmr/mddnmr-2.2.ebuild b/sci-chemistry/mddnmr/mddnmr-2.2.ebuild
new file mode 100644
index 000000000..dca9b27fb
--- /dev/null
+++ b/sci-chemistry/mddnmr/mddnmr-2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+
+REL="24Sep2012"
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Program for processing of non-uniformly sampled (NUS) multidimensional NMR spectra"
+HOMEPAGE="http://www.nmr.gu.se/~mdd/"
+SRC_URI="http://pc8.nmr.gu.se/~mdd/Downloads/${MY_P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="mddnmr"
+IUSE=""
+
+RDEPEND="
+ app-shells/tcsh
+ sci-chemistry/nmrpipe"
+DEPEND=""
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"/${PN}
+
+QA_PREBUILT="opt/${PN}/.*"
+
+src_install() {
+ exeinto /opt/${PN}/com
+ doexe com/*
+
+ exeinto /opt/${PN}/bin
+ if use amd64; then
+ doexe binLinux64Static/*
+ elif use x86; then
+ doexe binLinux32Static/*
+ fi
+
+ insinto /opt/${PN}/
+ doins -r GUI
+
+ cat >> "${T}"/qMDD <<- EOF
+ #!${EPREFIX}/bin/csh
+
+ setenv MDD_NMR "${EPREFIX}/opt/${PN}"
+ setenv MDD_NMRbin "${EPREFIX}/opt/${PN}/bin/"
+ setenv path=( . "$MDD_NMRbin" "${MDD_NMR}/com" )
+
+ csh "${EPREFIX}/opt/${PN}/GUI/qMDD"
+ EOF
+
+ dobin "${T}"/qMDD
+
+ dodoc *pdf
+}