aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-25 17:49:00 +0100
committerJustin Lecher <jlec@gentoo.org>2015-03-25 17:49:00 +0100
commit13f7c3aa371687e39edd4e85b1dc9e44dc05055d (patch)
treec62c6c46340fbf31b5e95d0a9fff400cb97c465c /sci-chemistry/mgltools-autodocktools
parentsci-chemistry/mgltools: Drop PYTHON_MODNAME and support for python2_6 (diff)
downloadsci-13f7c3aa371687e39edd4e85b1dc9e44dc05055d.tar.gz
sci-13f7c3aa371687e39edd4e85b1dc9e44dc05055d.tar.bz2
sci-13f7c3aa371687e39edd4e85b1dc9e44dc05055d.zip
sci-chemistry/mgltools-autodocktools: Drop PYTHON_MODNAME and support for python2_6
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-chemistry/mgltools-autodocktools')
-rw-r--r--sci-chemistry/mgltools-autodocktools/ChangeLog8
-rw-r--r--sci-chemistry/mgltools-autodocktools/mgltools-autodocktools-1.5.6.ebuild13
2 files changed, 12 insertions, 9 deletions
diff --git a/sci-chemistry/mgltools-autodocktools/ChangeLog b/sci-chemistry/mgltools-autodocktools/ChangeLog
index a0207894e..ef8ec8581 100644
--- a/sci-chemistry/mgltools-autodocktools/ChangeLog
+++ b/sci-chemistry/mgltools-autodocktools/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-chemistry/mgltools-autodocktools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Mar 2015; Justin Lecher <jlec@gentoo.org>
+ mgltools-autodocktools-1.5.6.ebuild:
+ sci-chemistry/mgltools-autodocktools: Drop PYTHON_MODNAME and support for
+ python2_6
+
10 Jun 2013; Justin Lecher <jlec@gentoo.org>
mgltools-autodocktools-1.5.6.ebuild:
Add missing python use dep, move to virtual/python-imaging
@@ -89,4 +94,3 @@
18 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+mgltools-autodocktools-1.5.4.ebuild, +metadata.xml:
Initial checkin
-
diff --git a/sci-chemistry/mgltools-autodocktools/mgltools-autodocktools-1.5.6.ebuild b/sci-chemistry/mgltools-autodocktools/mgltools-autodocktools-1.5.6.ebuild
index 8bf261800..9c90208c0 100644
--- a/sci-chemistry/mgltools-autodocktools/mgltools-autodocktools-1.5.6.ebuild
+++ b/sci-chemistry/mgltools-autodocktools/mgltools-autodocktools-1.5.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk"
inherit distutils-r1 eutils
@@ -12,8 +12,6 @@ inherit distutils-r1 eutils
MY_PN="AutoDockTools"
MY_P="${MY_PN}-${PV/_rc3/}"
-PYTHON_MODNAME="${MY_PN}"
-
DESCRIPTION="MGLTools Plugin -- AutoDockTools"
HOMEPAGE="http://mgltools.scripps.edu"
SRC_URI="http://mgltools.scripps.edu/downloads/tars/releases/REL${PV}/mgltools_source_${PV}.tar.gz"
@@ -24,7 +22,6 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
- virtual/python-imaging[tk,${PYTHON_USEDEP}]
dev-python/zsi[${PYTHON_USEDEP}]
sci-chemistry/autodock
sci-chemistry/mgltools-dejavu[${PYTHON_USEDEP}]
@@ -36,7 +33,9 @@ RDEPEND="
sci-chemistry/mgltools-pybabel[${PYTHON_USEDEP}]
sci-chemistry/mgltools-pyglf[${PYTHON_USEDEP}]
sci-chemistry/mgltools-support[${PYTHON_USEDEP}]
- sci-chemistry/mgltools-viewer-framework[${PYTHON_USEDEP}]"
+ sci-chemistry/mgltools-viewer-framework[${PYTHON_USEDEP}]
+ virtual/python-imaging[tk,${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}
dev-lang/swig"
@@ -64,5 +63,5 @@ python_install_all() {
distutils-r1_python_install_all
sed '1s:^.*$:#!/usr/bin/python:g' -i AutoDockTools/bin/runAdt || die
- dobin AutoDockTools/bin/runAdt
+ python_foreach_impl python_doscript AutoDockTools/bin/runAdt
}