aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-05-19 10:32:15 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-05-19 10:32:15 +0200
commit87826f27abc48b8e22b4b767b9bf259e174ac727 (patch)
tree81df2017ddb752f4037706ad03b945e26a221405 /sci-chemistry/mgltools-stride
parentsci-chemistry/mgltools-support fixup (diff)
downloadsci-87826f27abc48b8e22b4b767b9bf259e174ac727.tar.gz
sci-87826f27abc48b8e22b4b767b9bf259e174ac727.tar.bz2
sci-87826f27abc48b8e22b4b767b9bf259e174ac727.zip
sci-chemistry/mgltools-stride fixup
Diffstat (limited to 'sci-chemistry/mgltools-stride')
-rw-r--r--sci-chemistry/mgltools-stride/Manifest2
-rw-r--r--sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild21
2 files changed, 22 insertions, 1 deletions
diff --git a/sci-chemistry/mgltools-stride/Manifest b/sci-chemistry/mgltools-stride/Manifest
index 264f45b73..c6d667906 100644
--- a/sci-chemistry/mgltools-stride/Manifest
+++ b/sci-chemistry/mgltools-stride/Manifest
@@ -1,4 +1,4 @@
DIST mgltools_source_1.5.4.tar.gz 21503548 RMD160 0b8f7cfe8d808db72bf5c1ea24b5fdd08f8b519c SHA1 ef2e7e1fd48271f9d1676497af37061742931a81 SHA256 1fead1e3a45a87c5db90d44b1cf4d29a73846e162e3fa5e9c20a912320e49866
-EBUILD mgltools-stride-1.5.4.ebuild 640 RMD160 6fe9af7298c3a5cc6224b0ebf6a5e1e01bf8edde SHA1 080891a18fed685aeb198160e2342e247596f6db SHA256 5edf059263e4429bcdc35afa23e1979d614536da06b8cc3347861241c0421685
+EBUILD mgltools-stride-1.5.4.ebuild 1202 RMD160 b9fcb42aa5ade3288b002dc763f24c5f09241e3f SHA1 78bdaaa52d207d5713d4d4f3b842d9345c6fbc10 SHA256 8d5284f1c35a0d374929fb5d69f249a358a8443dfaf16c27936b565b4805a6b8
MISC ChangeLog 290 RMD160 5c08ee06a580c5f7ddc08c98eef61f472800fcbe SHA1 e82fa8475c50844ca714a3676603013427001a74 SHA256 c7b93828599a662a5ae31b3244705b7b220136aac3ffe83c230c0dbf575c354e
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild b/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild
index b1bf2d299..40264c549 100644
--- a/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild
+++ b/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild
@@ -27,3 +27,24 @@ src_unpack() {
}
+src_unpack() {
+ tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
+ tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
+
+ find "${S}" -name CVS -type d -exec rm -rf '{}' \; >& /dev/null
+ find "${S}" -name LICENSE -type f -exec rm -f '{}' \; >& /dev/null
+
+ sed \
+ -e 's:^.*CVS:#&1:g' \
+ -e 's:^.*LICENSE:#&1:g' \
+ -i "${S}"/MANIFEST.in
+}
+
+src_install() {
+ mglpath="$(python_get_sitedir)/MGLToolsPckgs/"
+
+ distutils_src_install \
+ --install-purelib="${mglpath}" \
+ --install-platlib="${mglpath}" \
+ --install-scripts="${mglpath}"
+}