aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-27 22:56:50 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-27 23:10:04 +0200
commitf21274d13f0b07e5a4fd11ae093ffa436122528b (patch)
tree7af5b446288cd473e5c01faa0e4e4661dbbfc13e /sci-chemistry/mgltools-stride
parentPython ABI fixes (diff)
downloadsci-f21274d13f0b07e5a4fd11ae093ffa436122528b.tar.gz
sci-f21274d13f0b07e5a4fd11ae093ffa436122528b.tar.bz2
sci-f21274d13f0b07e5a4fd11ae093ffa436122528b.zip
Python ABI fixes
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-chemistry/mgltools-stride')
-rw-r--r--sci-chemistry/mgltools-stride/ChangeLog8
-rw-r--r--sci-chemistry/mgltools-stride/Manifest14
-rw-r--r--sci-chemistry/mgltools-stride/mgltools-stride-1.5.4-r1.ebuild (renamed from sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild)26
3 files changed, 38 insertions, 10 deletions
diff --git a/sci-chemistry/mgltools-stride/ChangeLog b/sci-chemistry/mgltools-stride/ChangeLog
index 4480cce22..b0a7c6250 100644
--- a/sci-chemistry/mgltools-stride/ChangeLog
+++ b/sci-chemistry/mgltools-stride/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-chemistry/mgltools-stride
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mgltools-stride-1.5.4-r1 (27 Jun 2010)
+
+ 27 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ -mgltools-stride-1.5.4.ebuild, +mgltools-stride-1.5.4-r1.ebuild:
+ Python ABI fixes
+
19 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
mgltools-stride-1.5.4.ebuild:
missing license added
diff --git a/sci-chemistry/mgltools-stride/Manifest b/sci-chemistry/mgltools-stride/Manifest
index 7291e478e..efba3eaa5 100644
--- a/sci-chemistry/mgltools-stride/Manifest
+++ b/sci-chemistry/mgltools-stride/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST mgltools_source_1.5.4.tar.gz 21591865 RMD160 faa158477c4e9156ee5fd23b89251e5bedbd689d SHA1 3b3056a75cd944a4aa46771e09916a4e85052b88 SHA256 d0c614e167512bd19127c741cb2d9860443c097f7ccf0bbe244c0b155e59a9c2
-EBUILD mgltools-stride-1.5.4.ebuild 1102 RMD160 878a2f14e0df943ca300d3a227cba72e0cbe84df SHA1 d9dd49a6751f62971b33187ddc6a2fb60100b759 SHA256 18876586e6fe6220f80ba2cf43e6dd49aeff2a4737ff9d1a6ecc5d77b5e7661e
-MISC ChangeLog 404 RMD160 118badfbabf9a3c955e72322e9a9dce2b768a53f SHA1 f57df40c64b4a9ff8712b75637b131cdbeca5090 SHA256 ce6ba5eed45cc2d4a542e592aa4e2f647da0beccf9f17bd7ea71957c639e5b1f
+EBUILD mgltools-stride-1.5.4-r1.ebuild 1186 RMD160 956bf93ceaeccbb16341d2d64927e45c1c7a34ba SHA1 ba07c488e63364f13841a38e29d4985d5217a6c6 SHA256 a8f22fbb90bdc0edc072cb50f2784db8dbadece7e979e74a490ae56acc6b9bd4
+MISC ChangeLog 579 RMD160 5c193c45dd790e997e56c40cd4bcdcac26fadfc6 SHA1 9b96a4be5475212c264eca0e28129653c0075e8f SHA256 4d24e869592c1bffd99f991e4159d1f0a85e50a35c10835fa8d15e80ba1c17f4
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwnuxIACgkQgAnW8HDreRZAFQCfXMSlo5oR76CIukPaXL0v5Mwx
+nIsAniMYcnlK5ypJUZbzS+desQP9bNd4
+=/Lzv
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild b/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4-r1.ebuild
index 6c23f1ed8..9465b8573 100644
--- a/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4.ebuild
+++ b/sci-chemistry/mgltools-stride/mgltools-stride-1.5.4-r1.ebuild
@@ -1,10 +1,16 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
inherit distutils
-MY_P="${P/mgltools-}"
+MY_PN="stride"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="mgltools plugin -- stride"
HOMEPAGE="http://mgltools.scripps.edu/"
@@ -20,6 +26,7 @@ RDEPEND="dev-python/numpy"
DEPEND="${RDEPEND}
dev-lang/swig"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}"/${MY_P}
src_unpack() {
@@ -27,11 +34,7 @@ src_unpack() {
tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
}
-
-src_unpack() {
- tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
- tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
-
+src_prepare() {
find "${S}" -name CVS -type d -exec rm -rf '{}' \; >& /dev/null
find "${S}" -name LICENSE -type f -exec rm -f '{}' \; >& /dev/null
@@ -39,4 +42,13 @@ src_unpack() {
-e 's:^.*CVS:#&1:g' \
-e 's:^.*LICENSE:#&1:g' \
-i "${S}"/MANIFEST.in
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ python_mod_optimize ${MY_PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${MY_PN}
}