aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-18 10:54:00 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-18 11:05:22 +0200
commit4e6c9699879f9b618a8ea9702f5e256da715eb82 (patch)
treec290c4c53e75d07d37d834efdf6829b5bb63cdd1 /sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild
parentsci-chemistry/talosn: New package (diff)
downloadsci-4e6c9699879f9b618a8ea9702f5e256da715eb82.tar.gz
sci-4e6c9699879f9b618a8ea9702f5e256da715eb82.tar.bz2
sci-4e6c9699879f9b618a8ea9702f5e256da715eb82.zip
sci-chemistry/mics: New package
Package-Manager: portage-2.2.0_alpha180
Diffstat (limited to 'sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild')
-rw-r--r--sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild b/sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild
new file mode 100644
index 000000000..5f86a08f4
--- /dev/null
+++ b/sci-chemistry/mics/mics-1.00.2011.327.12.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit java-pkg-opt-2
+
+DESCRIPTION="Prediction of Protein Structural Motifs from NMR Chemical Shifts"
+HOMEPAGE="http://spin.niddk.nih.gov/bax/software/MICS/"
+SRC_URI="http://spin.niddk.nih.gov/bax/software/MICS/mics.tar.Z -> ${P}.tgz"
+
+SLOT="0"
+LICENSE="all-rights-reserved"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/MICS
+
+QA_PREBUILT="/opt/.*"
+
+src_prepare() {
+ rm -f bin/MICS.{mac,static.*,exe} || die
+}
+
+src_install() {
+ local MICS="/opt/${PN}"
+ exeinto /opt/bin
+ newexe bin/MICS* ${PN}
+
+ insinto ${MICS}
+ doins -r tab
+
+ java-pkg_jarinto ${MICS}
+ java-pkg_dojar bin/rama.jar
+
+ java-pkg_dolauncher jrama+ --jar rama.jar -into /opt/
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r demo
+ fi
+
+ cat >> "${T}"/40MICS <<- EOF
+ MICS_DIR="${EPREFIX}/${MICS}"
+ EOF
+ doenvd "${T}"/40MICS
+}