aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-16 10:38:30 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-09-16 10:38:30 -0600
commitb2436002f8aff35c6b91b193e60b4cd098ba1527 (patch)
tree32950e9c5aa9a1920a4fc4f17bf94896ac9ed43d /sci-chemistry/openbabel-perl
parentquote vars (diff)
downloadsci-b2436002f8aff35c6b91b193e60b4cd098ba1527.tar.gz
sci-b2436002f8aff35c6b91b193e60b4cd098ba1527.tar.bz2
sci-b2436002f8aff35c6b91b193e60b4cd098ba1527.zip
quote vars
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'sci-chemistry/openbabel-perl')
-rw-r--r--sci-chemistry/openbabel-perl/ChangeLog5
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/sci-chemistry/openbabel-perl/ChangeLog b/sci-chemistry/openbabel-perl/ChangeLog
index 38e6e1436..88e2b3515 100644
--- a/sci-chemistry/openbabel-perl/ChangeLog
+++ b/sci-chemistry/openbabel-perl/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Sep 2014; Christoph Junghans <ottxor@gentoo.org>
+ openbabel-perl-9999.ebuild:
+ quote vars
+
14 Feb 2014; Reinis Danne <rei4dan@gmail.com> openbabel-perl-9999.ebuild:
Fix move to git-r3.
@@ -13,4 +17,3 @@
26 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-perl-9999.ebuild,
+metadata.xml:
Add live ebuild.
-
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
index 2c54899ca..207a1b43f 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
@@ -28,14 +28,15 @@ src_unpack() {
src_configure() {
perl_set_version
- local mycmakeargs="${mycmakeargs}
+ local mycmakeargs=(
-DCMAKE_INSTALL_RPATH=
-DBINDINGS_ONLY=ON
- -DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
- -DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
- -DLIB_INSTALL_DIR=${ED}/${VENDOR_ARCH}
+ -DBABEL_SYSTEM_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libopenbabel.so
+ -DOB_MODULE_PATH="${EPREFIX}"/usr/$(get_libdir)/openbabel/${PV}
+ -DLIB_INSTALL_DIR="${ED}/${VENDOR_ARCH}"
-DPERL_BINDINGS=ON
- -DRUN_SWIG=ON"
+ -DRUN_SWIG=ON
+ )
cmake-utils_src_configure
}