aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 08:52:51 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 08:52:51 +0100
commitc6ef627cb6b787a92c3f109df23b7c90074a53b7 (patch)
tree1eefc5ad82b8b970279f54dce7c9a1d29d52c6e3 /sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
parentsci-chemistry/openbabel-ruby: Respect CXXFLAGS (diff)
downloadsci-c6ef627cb6b787a92c3f109df23b7c90074a53b7.tar.gz
sci-c6ef627cb6b787a92c3f109df23b7c90074a53b7.tar.bz2
sci-c6ef627cb6b787a92c3f109df23b7c90074a53b7.zip
sci-chemistry/openbabel-python: Fix sanbox problems during installation
respect CXXFLAGS Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570516 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/openbabel-python/openbabel-python-9999.ebuild')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
index 03c35f66e..b80dcf986 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,12 +47,13 @@ src_configure() {
my_impl_src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_RPATH=
+ -DOPTIMIZE_NATIVE=OFF
-DBINDINGS_ONLY=ON
-DBABEL_SYSTEM_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libopenbabel.so"
-DOB_MODULE_PATH="${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}"
- -DLIB_INSTALL_DIR="${D}$(python_get_sitedir)"
-DPYTHON_BINDINGS=ON
-DPYTHON_EXECUTABLE=${PYTHON}
+ -DCMAKE_INSTALL_PREFIX="${D}/usr"
-DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
-DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
-DPYTHON_LIBRARY="$(python_get_library_path)"