aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2013-11-14 19:28:36 +0200
committerReinis Danne <rei4dan@gmail.com>2013-11-14 19:28:36 +0200
commiteb968aa7ed7578f013aa2a04a52f47a1d04e6e0e (patch)
tree6de35ca35fbeaf26d578dfd7947c5e3aa0f01f57 /sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
parentsci-chemistry/openbabel: Adjust for README -> README.md rename (diff)
downloadsci-eb968aa7ed7578f013aa2a04a52f47a1d04e6e0e.tar.gz
sci-eb968aa7ed7578f013aa2a04a52f47a1d04e6e0e.tar.bz2
sci-eb968aa7ed7578f013aa2a04a52f47a1d04e6e0e.zip
sci-chemistry/openbabel-python: Let CMake find module dir
Diffstat (limited to 'sci-chemistry/openbabel-python/openbabel-python-9999.ebuild')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
index f0b113268..de787dde8 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -50,7 +50,6 @@ src_configure() {
-DBINDINGS_ONLY=ON
-DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
-DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
- -DLIB_INSTALL_DIR=${ED}/usr/$(get_libdir)/${EPYTHON}/site-packages
-DPYTHON_BINDINGS=ON
-DPYTHON_EXECUTABLE=${PYTHON}
-DPYTHON_INCLUDE_DIR=${EPREFIX}/usr/include/${EPYTHON}
@@ -75,7 +74,7 @@ src_install() {
my_impl_src_install() {
cd "${BUILD_DIR}" || die
- cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ DESTDIR=${ED} cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
python_optimize
}