aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 20:35:27 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 20:35:27 +0100
commitf36461f6a9cdfb88e0098e02eea73a1d4d7c6189 (patch)
tree4a3b685d3858e4b9df18d958e8e92bf0af2668e4 /sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
parentsci-chemistry/mdsctk: drop pack, last update 2015, no compat w. gromacs::gentoo (diff)
downloadsci-f36461f6a9cdfb88e0098e02eea73a1d4d7c6189.tar.gz
sci-f36461f6a9cdfb88e0098e02eea73a1d4d7c6189.tar.bz2
sci-f36461f6a9cdfb88e0098e02eea73a1d4d7c6189.zip
sci-chemistry/openbabel-python: remove pack, py2 only
All versions compatible with openbabel::gentoo are py2 only There is a PR open to ::gentoo to bump openbabel and add py3 compatible version of openbabel-python to ::gentoo https://github.com/gentoo/gentoo/pull/16182/files Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-chemistry/openbabel-python/openbabel-python-9999.ebuild')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
deleted file mode 100644
index 7d4ab0f8e..000000000
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
-
-inherit cmake-utils eutils git-r3 multilib python-r1
-
-DESCRIPTION="Python bindings for OpenBabel (including Pybel)"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~sci-chemistry/openbabel-${PV}
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2"
-
-src_prepare() {
- cmake-utils_src_prepare
- sed \
- -e "s:\"\.\.\":\"${EPREFIX}/usr\":g" \
- -i test/testbabel.py || die
- swig -python -c++ -small -O -templatereduce -naturalvar \
- -I"${EPREFIX}/usr/include/openbabel-2.0" \
- -o scripts/python/openbabel-python.cpp \
- -DHAVE_EIGEN \
- -outdir scripts/python \
- scripts/openbabel-python.i \
- || die "Regeneration of openbabel-python.cpp failed"
-}
-
-src_configure() {
- my_impl_src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_RPATH=
- -DOPTIMIZE_NATIVE=OFF
- -DBINDINGS_ONLY=ON
- -DBABEL_SYSTEM_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libopenbabel.so"
- -DOB_MODULE_PATH="${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}"
- -DPYTHON_BINDINGS=ON
- -DPYTHON_EXECUTABLE=${PYTHON}
- -DCMAKE_INSTALL_PREFIX="${D}/usr"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- -DENABLE_TESTS=ON
- )
-
- cmake-utils_src_configure
- }
-
- python_foreach_impl my_impl_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make bindings_python
-}
-
-src_test() {
- python_foreach_impl cmake-utils_src_test -R py
-}
-
-src_install() {
- my_impl_src_install() {
- cd "${BUILD_DIR}" || die
-
- cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
-
- python_optimize
- }
-
- python_foreach_impl my_impl_src_install
-}