aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-26 09:12:31 +0100
committerJustin Lecher <jlec@gentoo.org>2012-11-26 15:25:37 +0100
commit3cc853d6f4c6c1bcd94d8b256c6ab93355b583c3 (patch)
tree4ecb5293e68f1761fd579adf0c882fd18a69d934 /sci-chemistry/openbabel
parentsci-biology/staden: Version Bump, move to sane portage like building (diff)
downloadsci-3cc853d6f4c6c1bcd94d8b256c6ab93355b583c3.tar.gz
sci-3cc853d6f4c6c1bcd94d8b256c6ab93355b583c3.tar.bz2
sci-3cc853d6f4c6c1bcd94d8b256c6ab93355b583c3.zip
sci-chemistry/openbabel: Add test phase, check openmp correctly
Package-Manager: portage-2.2.0_alpha142
Diffstat (limited to 'sci-chemistry/openbabel')
-rw-r--r--sci-chemistry/openbabel/ChangeLog3
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.2.ebuild16
2 files changed, 16 insertions, 3 deletions
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
index fc85dc342..fdd934a61 100644
--- a/sci-chemistry/openbabel/ChangeLog
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Nov 2012; Justin Lecher <jlec@gentoo.org> openbabel-2.3.2.ebuild:
+ Add test phase, check openmp correctly
+
*openbabel-2.3.2 (19 Oct 2012)
19 Oct 2012; Reinis Danne <rei4dan@gmail.com> +openbabel-2.3.2.ebuild,
diff --git a/sci-chemistry/openbabel/openbabel-2.3.2.ebuild b/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
index a44d835aa..4be6337c1 100644
--- a/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
@@ -12,13 +12,13 @@ DESCRIPTION="Interconverts file formats used in molecular modeling"
HOMEPAGE="http://openbabel.sourceforge.net/"
SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
LICENSE="GPL-2"
-IUSE="doc openmp perl python wxwidgets"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp perl python test wxwidgets"
RDEPEND="
- dev-cpp/eigen:=
+ dev-cpp/eigen:3
dev-libs/libxml2:2
!sci-chemistry/babel
sci-libs/inchi
@@ -34,6 +34,16 @@ DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
PATCHES=( "${FILESDIR}"/${P}-test_lib_path.patch )
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+}
+
src_configure() {
local mycmakeargs=""
mycmakeargs="${mycmakeargs}