aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-24 10:01:34 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-24 10:01:34 +0200
commit2c9669edfecf6c434a367dea96f4140da4e61389 (patch)
tree7388e84b2c28f2472b8678467868a8950cbd77dc /sci-chemistry/pymol/files
parentsci-libs/cbflib QA rpath and soname fixed (diff)
downloadsci-2c9669edfecf6c434a367dea96f4140da4e61389.tar.gz
sci-2c9669edfecf6c434a367dea96f4140da4e61389.tar.bz2
sci-2c9669edfecf6c434a367dea96f4140da4e61389.zip
fix for bug 282503
Diffstat (limited to 'sci-chemistry/pymol/files')
-rw-r--r--sci-chemistry/pymol/files/1.2.1/nosplash-gentoo.patch9
-rw-r--r--sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-data-path.patch30
-rw-r--r--sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-shaders.patch10
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/files/1.2.1/nosplash-gentoo.patch b/sci-chemistry/pymol/files/1.2.1/nosplash-gentoo.patch
new file mode 100644
index 000000000..3125b2856
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.2.1/nosplash-gentoo.patch
@@ -0,0 +1,9 @@
+--- modules/pymol/invocation.py 2009-06-25 17:26:27.000000000 +0200
++++ modules/pymol/invocation.py.new 2009-06-25 17:41:57.000000000 +0200
+@@ -395,6 +395,4 @@
+ if loaded_something and (options.after_load_script!=""):
+ options.deferred.append(options.after_load_script)
+ options.deferred.extend(final_actions)
+- if options.show_splash and not options.no_gui and not restricted:
+- options.deferred.insert(0,"_do__ cmd.splash(1)")
+
diff --git a/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-data-path.patch b/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-data-path.patch
new file mode 100644
index 000000000..86c3fe1f1
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-data-path.patch
@@ -0,0 +1,30 @@
+diff -arNu -uarN pymol/modules/pymol/commanding.py pymol.new/modules/pymol/commanding.py
+--- pymol/modules/pymol/commanding.py 2009-03-31 12:43:14.585834066 +0200
++++ pymol.new/modules/pymol/commanding.py 2009-03-31 12:44:26.436354330 +0200
+@@ -219,11 +219,11 @@
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+diff -arNu -uarN pymol/modules/pymol/importing.py pymol.new/modules/pymol/importing.py
+--- pymol/modules/pymol/importing.py 2009-03-31 12:43:14.546250540 +0200
++++ pymol.new/modules/pymol/importing.py 2009-03-31 12:44:48.876657949 +0200
+@@ -191,7 +191,7 @@
+ '''
+ r = DEFAULT_ERROR
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb' }
+
diff --git a/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-shaders.patch b/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-shaders.patch
new file mode 100644
index 000000000..06f756823
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.2.1/pymol-1.2.1-shaders.patch
@@ -0,0 +1,10 @@
+--- pymol-1.2_rc1/setup.py.old 2009-07-17 00:05:10.339203020 -0500
++++ pymol-1.2_rc1/setup.py 2009-07-17 00:09:03.375274561 -0500
+@@ -138,6 +138,7 @@
+ ("_PYMOL_INLINE",None),
+ ("_PYMOL_FREETYPE",None),
+ ("_PYMOL_LIBPNG",None),
++ ("_PYMOL_OPENGL_SHADERS",None),
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support