aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-20 10:15:44 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-20 10:15:44 +0100
commit5e8ea153fdb353bf081864d11783b1815d4da6fa (patch)
tree0bc00f4c4e2544ec395cdedacf2c7cc61965a35b /sci-chemistry/pymol/files
parentMerge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/sci (diff)
downloadsci-5e8ea153fdb353bf081864d11783b1815d4da6fa.tar.gz
sci-5e8ea153fdb353bf081864d11783b1815d4da6fa.tar.bz2
sci-5e8ea153fdb353bf081864d11783b1815d4da6fa.zip
sci-chemistry/pymol bumped to 1.2 beta 3
Diffstat (limited to 'sci-chemistry/pymol/files')
-rw-r--r--sci-chemistry/pymol/files/pymol-1.2_beta3-data-path.patch51
-rw-r--r--sci-chemistry/pymol/files/pymol-1.2_beta3-shaders.patch11
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/files/pymol-1.2_beta3-data-path.patch b/sci-chemistry/pymol/files/pymol-1.2_beta3-data-path.patch
new file mode 100644
index 000000000..329b68292
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.2_beta3-data-path.patch
@@ -0,0 +1,51 @@
+diff -urN pymol-9999.orig/modules/pymol/commanding.py pymol-9999/modules/pymol/commanding.py
+--- pymol-9999.orig/modules/pymol/commanding.py 2008-01-11 13:23:32.000000000 +0100
++++ pymol-9999/modules/pymol/commanding.py 2008-01-11 13:22:57.000000000 +0100
+@@ -198,11 +198,11 @@
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+#diff -urN pymol-9999.orig/modules/pymol/fitting.py pymol-9999/modules/pymol/fitting.py
+#--- pymol-9999.orig/modules/pymol/fitting.py 2008-01-11 13:23:32.000000000 +0100
+#+++ pymol-9999/modules/pymol/fitting.py 2008-01-11 13:23:00.000000000 +0100
+#@@ -68,7 +68,7 @@
+# if string.lower(matrix)=='none':
+# matrix=''
+# if len(matrix):
+#- mfile = cmd.exp_path("$PYMOL_PATH/data/pymol/matrices/"+matrix)
+#+ mfile = cmd.exp_path("$PYMOL_DATA/pymol/matrices/"+matrix)
+# else:
+# mfile = ''
+# # delete existing alignment object (if asked to reset it)
+#@@ -135,7 +135,7 @@
+# if string.lower(matrix)=='none':
+# matrix=''
+# if len(matrix):
+#- mfile = cmd.exp_path("$PYMOL_PATH/data/pymol/matrices/"+matrix)
+#+ mfile = cmd.exp_path("$PYMOL_DATA/pymol/matrices/"+matrix)
+# else:
+# mfile = ''
+# if object==None: object=''
+diff -urN pymol-9999.orig/modules/pymol/importing.py pymol-9999/modules/pymol/importing.py
+--- pymol-9999.orig/modules/pymol/importing.py 2008-01-11 13:23:32.000000000 +0100
++++ pymol-9999/modules/pymol/importing.py 2008-01-11 13:23:02.000000000 +0100
+@@ -171,7 +171,7 @@
+ r = DEFAULT_ERROR
+
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb' }
+
diff --git a/sci-chemistry/pymol/files/pymol-1.2_beta3-shaders.patch b/sci-chemistry/pymol/files/pymol-1.2_beta3-shaders.patch
new file mode 100644
index 000000000..7f4a24f48
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.2_beta3-shaders.patch
@@ -0,0 +1,11 @@
+diff -uarN pymol-9999.orig/setup.py pymol-9999/setup.py
+--- pymol-9999.orig/setup.py 2008-06-18 11:47:58.000000000 +0200
++++ pymol-9999/setup.py 2008-06-18 11:48:52.000000000 +0200
+@@ -143,6 +143,7 @@
+ def_macros=[("_PYMOL_MODULE",None),
+ ("_PYMOL_INLINE",None),
+ ("_PYMOL_FREETYPE",None),
++ ("_PYMOL_OPENGL_SHADERS",None),
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support