aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-29 15:27:41 +0100
committerJustin Lecher <jlec@gentoo.org>2011-11-29 15:27:41 +0100
commit85c49f7d25ad36be2ee4ed276874aab260ba15da (patch)
tree911a0d1ecd0f5e8f358f255bf2f9d39bce060ea2 /sci-chemistry/simpson/simpson-3.1.0.ebuild
parentNew package, ebuild written by me (diff)
downloadsci-85c49f7d25ad36be2ee4ed276874aab260ba15da.tar.gz
sci-85c49f7d25ad36be2ee4ed276874aab260ba15da.tar.bz2
sci-85c49f7d25ad36be2ee4ed276874aab260ba15da.zip
Version BUmp, added missing dep, found by louic and reported in irc
(Portage version: 2.2.0_alpha79/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/simpson/simpson-3.1.0.ebuild')
-rw-r--r--sci-chemistry/simpson/simpson-3.1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/simpson/simpson-3.1.0.ebuild b/sci-chemistry/simpson/simpson-3.1.0.ebuild
new file mode 100644
index 000000000..b46c55928
--- /dev/null
+++ b/sci-chemistry/simpson/simpson-3.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils prefix
+
+DESCRIPTION="General-purpose software package for simulation virtually all kinds of solid-state NMR experiments"
+HOMEPAGE="http://bionmr.chem.au.dk/bionmr/software/index.php"
+SRC_URI="http://www.bionmr.chem.au.dk/download/${PN}/3.1/${PN}-source-${PV}.tbz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+LICENSE="GPL-2"
+IUSE="gtk threads tk"
+
+RDEPEND="
+ dev-libs/libf2c
+ virtual/blas
+ virtual/cblas
+ virtual/lapack
+ gtk? ( x11-libs/gtk+:1 )
+ tk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-source-${PV}
+
+src_prepare() {
+ edos2unix Makefile
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ epatch "${FILESDIR}"/3.0.1-type.patch
+ eprefixify Makefile
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}