aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-26 22:56:40 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-26 22:57:29 +0200
commit6be9bcdec7f0416350d773afd9ca7f8c579548de (patch)
tree94b763a4f54f7ed2cc933909bc427c92fd1c02c7 /sci-chemistry/tinker
parentsci-chemistry/jligand -- written by me (diff)
downloadsci-6be9bcdec7f0416350d773afd9ca7f8c579548de.tar.gz
sci-6be9bcdec7f0416350d773afd9ca7f8c579548de.tar.bz2
sci-6be9bcdec7f0416350d773afd9ca7f8c579548de.zip
tinker bump to 5.0
Diffstat (limited to 'sci-chemistry/tinker')
-rw-r--r--sci-chemistry/tinker/ChangeLog6
-rw-r--r--sci-chemistry/tinker/Manifest4
-rw-r--r--sci-chemistry/tinker/tinker-5.0.ebuild (renamed from sci-chemistry/tinker/tinker-4.2-r2.ebuild)12
3 files changed, 14 insertions, 8 deletions
diff --git a/sci-chemistry/tinker/ChangeLog b/sci-chemistry/tinker/ChangeLog
index f45afcb07..ab0c5cae7 100644
--- a/sci-chemistry/tinker/ChangeLog
+++ b/sci-chemistry/tinker/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.10 2008/11/06 23:53:23 dberkholz Exp $
+*tinker-5.0 (26 Jul 2009)
+
+ 26 Jul 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ -tinker-4.2-r2.ebuild, +tinker-5.0.ebuild:
+ version bump
+
24 Apr 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
tinker-4.2-r2.ebuild:
~amd64 added see bug 263006
diff --git a/sci-chemistry/tinker/Manifest b/sci-chemistry/tinker/Manifest
index 558cb6b85..d1e0331d8 100644
--- a/sci-chemistry/tinker/Manifest
+++ b/sci-chemistry/tinker/Manifest
@@ -1,4 +1,4 @@
DIST tinker.tar.gz 8177555 RMD160 95f904f03f6a1767bbf73b00f326d19a164b7a1c SHA1 b42c5763958869894ee91fcd2ed4c5e03d8c1e5d SHA256 ad0cc9782dabdb0cce490fe26508761a36078e741f019090cbaa3e6cacf71055
-EBUILD tinker-4.2-r2.ebuild 1845 RMD160 f2f6aea11bd427d0d6a2e8ac55c99955c2973cb7 SHA1 defb9d66d120c1f3556a4223b64a32069c3fde40 SHA256 0af0b95c61c33ddb64de255911e78d88c7c4710e9825b43c61efb8d39a4f6cdb
-MISC ChangeLog 2225 RMD160 d9bd5aa28ebc0d496c2b24dde56a8d65e4b8f0ec SHA1 d7b97aa53272cac7ba4f06f8d9908e7d87178dd6 SHA256 07b64eeb84df091b330ed343329753e47067b6045a24ceeb1bc80d8a194524b8
+EBUILD tinker-5.0.ebuild 1845 RMD160 9099d5e35f26521a1daced4e2c420d749f51cb14 SHA1 aa2953ee8745008a6a999687b49603e09ca8904b SHA256 22c6bb14b4a9b2992ac690afea8b0f251aabd52a809bbb210d570c72ff999e97
+MISC ChangeLog 2370 RMD160 8b5d727c2720d348f6f00ff0846c505b71746e27 SHA1 f34a340ee01f2a597b8e17acc2f2da39c9d85dcb SHA256 5395df8360f6dd6700e0bc1c8957a5f42c663be966c6319c6e86e7f8bf1a88b0
MISC metadata.xml 166 RMD160 4452298fd03e7c9395d1182bfe69d60a14144af6 SHA1 cb0b513473c0348f4f6f6cd9a132e4884155fddb SHA256 84c92b49702daf95eace8d2765215cbd8650da4ef776f9f700b5ce3785dec852
diff --git a/sci-chemistry/tinker/tinker-4.2-r2.ebuild b/sci-chemistry/tinker/tinker-5.0.ebuild
index 32ecab9b7..84f989021 100644
--- a/sci-chemistry/tinker/tinker-4.2-r2.ebuild
+++ b/sci-chemistry/tinker/tinker-5.0.ebuild
@@ -4,7 +4,7 @@
inherit fortran toolchain-funcs
-FORTRAN="g77 gfortran ifc"
+FORTRAN="gfortran ifc"
DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM."
HOMEPAGE="http://dasher.wustl.edu/tinker/"
@@ -27,17 +27,17 @@ src_compile() {
if [[ ${FORTRANC} == "ifc" ]]; then
cp ../linux/intel/* .
else
- cp ../linux/gnu/* .
+ cp ../linux/gfortran/* .
fi
cp ../make/* .
# Prep build scripts
- sed -i -e "s:g77:${FORTRANC} ${LDFLAGS}:g" ${LINK}
+ sed -i -e "s:gfortran:${FORTRANC} ${LDFLAGS}:g" ${LINK}
# Default to -O2 if FFLAGS is unset
- sed -i -e "s:-O3 -ffast-math:${FFLAGS:- -O2}:" ${COMPILE}
- sed -i -e "s:g77:${FORTRANC}:g" ${COMPILE}
+ sed -i -e "s:-O:${FFLAGS:- -O2}:" ${COMPILE}
+ sed -i -e "s:gfortran:${FORTRANC}:g" ${COMPILE}
einfo "Compiling ..."
${COMPILE} || die "compile failed"
@@ -52,7 +52,7 @@ src_install() {
dodoc \
"${WORKDIR}"/tinker/doc/*.txt \
- "${WORKDIR}"/tinker/doc/release-4.2 \
+ "${WORKDIR}"/tinker/doc/release-${PV} \
"${WORKDIR}"/tinker/doc/*.pdf
dolib.a libtinker.a