aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <kleiner_otti@gmx.de>2010-12-05 13:22:46 +0100
committerChristoph Junghans <kleiner_otti@gmx.de>2010-12-05 13:22:46 +0100
commit19e3bb2014ccd9771ae9fa37ad8fcbf312d6d6ab (patch)
tree8e9b700eb97391342c6a457dc05b51af86bc8a35 /sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild
parent[sci-libs/votca-tools] version bump + clean up (diff)
downloadsci-19e3bb2014ccd9771ae9fa37ad8fcbf312d6d6ab.tar.gz
sci-19e3bb2014ccd9771ae9fa37ad8fcbf312d6d6ab.tar.bz2
sci-19e3bb2014ccd9771ae9fa37ad8fcbf312d6d6ab.zip
[sci-chemistry/votca-csg] version bump + clean up
(Portage version: 2.1.9.24/git/Linux i686, signed Manifest commit with key A9ECD7F9)
Diffstat (limited to 'sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild')
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild b/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild
new file mode 100644
index 000000000..7eb1babe6
--- /dev/null
+++ b/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit autotools bash-completion
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca coarse-graining engine"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +gromacs static-libs"
+
+RDEPEND="=sci-libs/votca-tools-${PV}
+ >=sci-chemistry/gromacs-4.0.7-r5
+ dev-lang/perl
+ app-shells/bash
+ doc? ( >=app-text/txt2tags-2.5 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ #from bootstrap.sh
+ [ -z "${PV##*9999}" ] && \
+ emake -C share/scripts/inverse -f Makefile.am.in Makefile.am
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ local myconf="--disable-la-files --disable-rc-files"
+
+ if use gromacs; then
+ #prefer gromacs double-precision if it is there
+ if has_version sci-chemistry/gromacs[double-precision]; then
+ myconf="${myconf} --with-libgmx=libgmx_d"
+ else
+ myconf="${myconf} --with-libgmx=libgmx"
+ fi
+ else
+ myconf="${myconf} --without-libgmx"
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README NOTICE
+ if use doc; then
+ emake CHANGELOG || die "emake CHANGELOG failed"
+ dodoc CHANGELOG
+ fi
+
+ dobashcompletion scripts/csg-completion.bash ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read and cite:"
+ elog "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ elog "http://dx.doi.org/10.1021/ct900369w"
+ elog
+ bash-completion_pkg_postinst
+}