aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-24 19:03:47 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-07-24 19:03:47 -0600
commit2afc0e41b8a115da85997f57a9c7e314a27c9017 (patch)
tree4311643dbf08fc31005dd927c998b1180c71da89 /sci-chemistry/votca-csg
parentnet-fs/cvmfs: Initial import, need more work (diff)
downloadsci-2afc0e41b8a115da85997f57a9c7e314a27c9017.tar.gz
sci-2afc0e41b8a115da85997f57a9c7e314a27c9017.tar.bz2
sci-2afc0e41b8a115da85997f57a9c7e314a27c9017.zip
sync with gx86
(Portage version: 2.2.0_alpha120/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog3
-rw-r--r--sci-chemistry/votca-csg/votca-csg-9999.ebuild25
2 files changed, 18 insertions, 10 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
index 78729df28..97ca527bb 100644
--- a/sci-chemistry/votca-csg/ChangeLog
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Jul 2012; Christoph Junghans <ottxor@gentoo.org> votca-csg-9999.ebuild:
+ sync with gx86
+
18 Jul 2012; Christoph Junghans <ottxor@gentoo.org> metadata.xml,
votca-csg-9999.ebuild:
live ebuild update
diff --git a/sci-chemistry/votca-csg/votca-csg-9999.ebuild b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
index 89dda5ac0..cd73981a6 100644
--- a/sci-chemistry/votca-csg/votca-csg-9999.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-9999.ebuild
@@ -7,11 +7,11 @@ EAPI=4
inherit bash-completion-r1 cmake-utils multilib
IUSE="doc examples extras +gromacs"
-PDEPEND="extras? ( =sci-chemistry/votca-csgapps-${PV} )"
+PDEPEND="extras? ( =sci-chemistry/${PN}apps-${PV} )"
if [ "${PV}" != "9999" ]; then
SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
- doc? ( http://votca.googlecode.com/files/votca-manual-${PV}.pdf )
- examples? ( http://votca.googlecode.com/files/votca-tutorials-${PV}.tar.gz )"
+ doc? ( http://votca.googlecode.com/files/${PN}-manual-${PV}.pdf )
+ examples? ( http://votca.googlecode.com/files/${PN}-tutorials-${PV}.tar.gz )"
RESTRICT="primaryuri"
else
SRC_URI=""
@@ -19,8 +19,8 @@ else
EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
EHG_REVISION="default"
S="${WORKDIR}/${EHG_REPO_URI##*/}"
- PDEPEND="${PDEPEND} doc? ( =app-doc/votca-csg-manual-${PV} )
- examples? ( =sci-chemistry/votca-csg-tutorials-${PV} )"
+ PDEPEND="${PDEPEND} doc? ( =app-doc/${PN}-manual-${PV} )
+ examples? ( =sci-chemistry/${PN}-tutorials-${PV} )"
fi
DESCRIPTION="Votca coarse-graining engine"
@@ -28,7 +28,7 @@ HOMEPAGE="http://www.votca.org"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
RDEPEND="=sci-libs/votca-tools-${PV}
gromacs? ( sci-chemistry/gromacs )
@@ -36,24 +36,29 @@ RDEPEND="=sci-libs/votca-tools-${PV}
app-shells/bash"
DEPEND="${RDEPEND}
- doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
>=app-text/txt2tags-2.5
virtual/pkgconfig"
DOCS=( README NOTICE )
src_configure() {
- local GMX_DEV="OFF" GMX_DOUBLE="OFF"
+ local GMX_DEV="OFF" GMX_DOUBLE="OFF" extra
if use gromacs; then
has_version =sci-chemistry/gromacs-9999 && GMX_DEV="ON"
has_version sci-chemistry/gromacs[double-precision] && GMX_DOUBLE="ON"
fi
+ #to create man pages, build tree binaries are executed (bug #398437)
+ [[ ${CHOST} = *-darwin* ]] && \
+ extra+=" -DCMAKE_BUILD_WITH_INSTALL_RPATH=OFF"
+
mycmakeargs=(
$(cmake-utils_use_with gromacs GMX)
-DWITH_GMX_DEVEL="${GMX_DEV}"
-DGMX_DOUBLE="${GMX_DOUBLE}"
+ ${extra}
-DWITH_RC_FILES=OFF
-DLIB=$(get_libdir)
)
@@ -65,7 +70,7 @@ src_install() {
cmake-utils_src_install
if use doc; then
if [ -n "${PV##*9999}" ]; then
- dodoc "${DISTDIR}/votca-manual-${PV}.pdf"
+ dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
fi
cd "${CMAKE_BUILD_DIR}" || die
emake html
@@ -74,7 +79,7 @@ src_install() {
if use examples && [ -n "${PV##*9999}" ]; then
insinto "/usr/share/doc/${PF}/tutorials"
docompress -x "/usr/share/doc/${PF}/tutorials"
- doins -r "${WORKDIR}/votca-tutorials-${PV}"/*
+ doins -r "${WORKDIR}/${PN}-tutorials-${PV}"/*
fi
}