aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 15:27:06 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 15:27:06 +0200
commit29dae412f4a072cefba2a5f7d4d8f9e2b2504b54 (patch)
tree8b8780f89cce1d85c17d6b3258bf79042079e9ad /sci-chemistry
parentsci-chemistry/polygon: Version BUmp; fixed license (diff)
downloadsci-29dae412f4a072cefba2a5f7d4d8f9e2b2504b54.tar.gz
sci-29dae412f4a072cefba2a5f7d4d8f9e2b2504b54.tar.bz2
sci-29dae412f4a072cefba2a5f7d4d8f9e2b2504b54.zip
sci-chemistry/pymol-plugins-ezviz: Bump to EAPI=5 and bump to python-r1.eclass
Package-Manager: portage-2.2.0_alpha180
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/ChangeLog4
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/Manifest2
-rw-r--r--sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild56
3 files changed, 27 insertions, 35 deletions
diff --git a/sci-chemistry/pymol-plugins-ezviz/ChangeLog b/sci-chemistry/pymol-plugins-ezviz/ChangeLog
index 1ccd39164..86dd9cb13 100644
--- a/sci-chemistry/pymol-plugins-ezviz/ChangeLog
+++ b/sci-chemistry/pymol-plugins-ezviz/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/sci-chemistry/pymol-plugins-ezviz/ChangeLog,v 1.2 2010/04/08 18:47:57 jlec dead $
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org>
+ pymol-plugins-ezviz-1.0.2005.ebuild:
+ Bump to EAPI=5 and bump to python-r1.eclass
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Fix missing DOCTYPE
diff --git a/sci-chemistry/pymol-plugins-ezviz/Manifest b/sci-chemistry/pymol-plugins-ezviz/Manifest
index d7b39ced4..900a20e11 100644
--- a/sci-chemistry/pymol-plugins-ezviz/Manifest
+++ b/sci-chemistry/pymol-plugins-ezviz/Manifest
@@ -1 +1 @@
-DIST pymol-plugins-ezviz-1.0.2005.zip 137431 SHA256 742c18d338ccc0567203c122a5f7ce0f903bf3247f7620337828d9dd5ae4f008
+DIST pymol-plugins-ezviz-1.0.2005.zip 137431 SHA256 742c18d338ccc0567203c122a5f7ce0f903bf3247f7620337828d9dd5ae4f008 SHA512 d0281e16dac76e519c725945bdaa5da233f8975411b9d39258a03206c39349014a05e52b6f8cd08b0c667e9d6a177eba2545861ee853ba43810f9ed0d4beb7a1 WHIRLPOOL 87deac54993ca87e4c61512f54d2c5063e9d641064780d999603d934c11755ad36bd211210c04f6a8e2bf302476b54ef8b3cad6efe1f7c0fa74378b549699366
diff --git a/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild
index 8e84a9af2..5f044c6e3 100644
--- a/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild
+++ b/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild
@@ -1,63 +1,51 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/sci-chemistry/pymol-plugins-ezviz/pymol-plugins-ezviz-1.0.2005.ebuild,v 1.2 2010/04/08 18:47:57 jlec dead $
-EAPI="3"
+EAPI=5
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python
+inherit eutils python-r1
-DESCRIPTION="assistance tool for the difficult to understand user interface of PyMOL"
+DESCRIPTION="Assistance tool for the difficult to understand user interface of PyMOL"
HOMEPAGE="http://www.rit.edu/cos/ezviz/index.html"
-SRC_URI="
- mirror://gentoo/${P}.zip
- mirror://gentoo/${P}.zip"
+SRC_URI="http://www.rit.edu/cos/ezviz/EZ_Viz.zip -> ${P}.zip"
SLOT="0"
+LICENSE="all-rights-reserved"
KEYWORDS="~amd64 ~x86"
-LICENSE="as-is"
IUSE="doc"
-RDEPEND="sci-chemistry/pymol"
-DEPEND="
- app-arch/unzip
- ${RDEPEND}"
-
-RESTRICT_PYTHON_ABIS="3.*"
+RDEPEND="sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip"
S="${WORKDIR}/EZ_Viz Folder"
src_prepare() {
edos2unix ez-viz.py
+ epatch "${FILESDIR}"/gentoo.patch
+ for gif in *.GIF; do
+ mv ${gif} ${gif/.GIF/.gif} || die
+ done
python_copy_sources
preperation() {
- epatch "${FILESDIR}"/gentoo.patch
+ cd "${BUILD_DIR}" || die
sed \
-e "s:GENTOOPYMOL:${EPREFIX}/$(python_get_sitedir):g" \
-i ez-viz.py || die
}
- python_execute_function -s preperation
+ python_foreach_impl preperation
}
src_install() {
installation() {
- insinto $(python_get_sitedir)/pmg_tk/startup/
- doins *.py || die
- insinto $(python_get_sitedir)/pmg_tk/startup/ez-viz/
- doins *.gif || die
- for gif in *.GIF; do
- newins ${gif} ${gif/.GIF/.gif} || die
- done
+ python_moduleinto pmg_tk/startup/
+ python_domodule *.py
+ python_moduleinto pmg_tk/startup/ez-viz/
+ python_domodule *.gif
}
- python_execute_function -s installation
- dodoc readme.txt || die
-}
-
-pkg_postinst() {
- python_mod_optimize pmg_tk/startup
-}
-
-pkg_postrm() {
- python_mod_cleanup pmg_tk/startup
+ python_foreach_impl installation
+ python_parallel_foreach_impl python_optimize
+ dodoc readme.txt
}