aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 08:25:48 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 08:25:48 +0100
commit3ba96f893fe3d245d76283e9f4fee235b10b0f18 (patch)
treea0d2f1ec490c5141e384ed78c9ea96f021efb0ad /sci-chemistry
parentsci-chemistry/openbabel: Respect CXXFLAGS (diff)
downloadsci-3ba96f893fe3d245d76283e9f4fee235b10b0f18.tar.gz
sci-3ba96f893fe3d245d76283e9f4fee235b10b0f18.tar.bz2
sci-3ba96f893fe3d245d76283e9f4fee235b10b0f18.zip
sci-chemistry/openbabel-perl: Respect CXXFLAGS
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-perl/metadata.xml2
-rw-r--r--sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/sci-chemistry/openbabel-perl/metadata.xml b/sci-chemistry/openbabel-perl/metadata.xml
index c73e211ef..506b159cc 100644
--- a/sci-chemistry/openbabel-perl/metadata.xml
+++ b/sci-chemistry/openbabel-perl/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
diff --git a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
index e61d4729d..ca1bc9880 100644
--- a/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
+++ b/sci-chemistry/openbabel-perl/openbabel-perl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,6 +29,7 @@ src_unpack() {
src_configure() {
perl_set_version
local mycmakeargs=(
+ -DOPTIMIZE_NATIVE=OFF
-DCMAKE_INSTALL_RPATH=
-DBINDINGS_ONLY=ON
-DBABEL_SYSTEM_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libopenbabel.so
@@ -50,14 +51,13 @@ src_test() {
cp \
"${CMAKE_USE_DIR}/scripts/perl/OpenBabel.pm" \
"${BUILD_DIR}/$(get_libdir)/Chemistry/"
- for i in "${CMAKE_USE_DIR}"/scripts/perl/t/*
- do
+ for i in "${CMAKE_USE_DIR}"/scripts/perl/t/*; do
einfo "Running test: ${i}"
perl -I"${BUILD_DIR}/$(get_libdir)" "${i}" || die
done
}
src_install() {
- cd "${BUILD_DIR}"
+ cd "${BUILD_DIR}" || die
cmake -DCOMPONENT=bindings_perl -P cmake_install.cmake
}