aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-15 08:18:12 +0200
committerJustin Lecher <jlec@gentoo.org>2013-05-15 08:18:12 +0200
commit7c8f5d5c7aeb909b1280d4c825f7e9c386a09093 (patch)
tree5f09ee6f154b6a57e2c1485de2de628b3f733f95 /sci-chemistry
parentMoved a variable definition. (diff)
downloadsci-7c8f5d5c7aeb909b1280d4c825f7e9c386a09093.tar.gz
sci-7c8f5d5c7aeb909b1280d4c825f7e9c386a09093.tar.bz2
sci-7c8f5d5c7aeb909b1280d4c825f7e9c386a09093.zip
sci-chemistry/curvefit: Add missing eclass inherit
Package-Manager: portage-2.2.0_alpha174 RepoMan-Options: --force
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/curvefit/ChangeLog3
-rw-r--r--sci-chemistry/curvefit/curvefit-1.40.ebuild6
2 files changed, 6 insertions, 3 deletions
diff --git a/sci-chemistry/curvefit/ChangeLog b/sci-chemistry/curvefit/ChangeLog
index d972ffb0b..4be6a2c16 100644
--- a/sci-chemistry/curvefit/ChangeLog
+++ b/sci-chemistry/curvefit/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 May 2013; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild:
+ Add missing eclass inherit
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> curvefit-1.40.ebuild,
metadata.xml:
Correct lib name of ref blas
diff --git a/sci-chemistry/curvefit/curvefit-1.40.ebuild b/sci-chemistry/curvefit/curvefit-1.40.ebuild
index 0e0c6ceb0..30ec27200 100644
--- a/sci-chemistry/curvefit/curvefit-1.40.ebuild
+++ b/sci-chemistry/curvefit/curvefit-1.40.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit multilib
+inherit fortran-2 multilib
DESCRIPTION="Linear and non-linear least squares fitting"
HOMEPAGE="http://cpmcnet.columbia.edu/dept/gsas/biochem/labs/palmer/software/curvefit.html"
@@ -33,9 +33,9 @@ src_install() {
exeinto /opt/bin
if use x86; then
- _exe=./linux_32/curvefit
+ _exe=./linux_32/${PN}
elif use amd64; then
- _exe=./linux_64/curvefit
+ _exe=./linux_64/${PN}
fi
patchelf --set-rpath "${EPREFIX}/opt/${PN}:${EPREFIX}/usr/$(get_libdir)/gcc/x86_64-pc-linux-gnu/4.1.2/" ${_exe}